1. Myster Dog
  2. Bugs
  3. Saturday, 23 February 2019
  4.  Subscribe via email
Hello.

I've installed CComment on my new website, since I have already installed it on a former website, and I was really satisfied.
The new version is really cool, but I have noticed a little bug : the name is displayed in the comments, whereas the username is displayed in quotes.
How can I display usernames everywhere ?
(The "display names" option is disabled in my settings).
Responses (14)
Accepted Answer Pending Moderation
Hi,

can you please provide URL to the page where we can see this issue?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 1
Accepted Answer Pending Moderation
Hi Igor.
Thanks for your answer.
The page is http://meal.creaweb38.fr/a-faire
I have written explanation comments on the site to illustrate what seems to be a bug.
  1. more than a month ago
  2. Bugs
  3. # 2
Accepted Answer Pending Moderation
Hi,

I have assigned the ticket to our developer so he can comment on this
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 3
Accepted Answer Pending Moderation
Thank you very much.
Does the developer need to access to my website ?
(The website is normally not accessible, at the request of the person for whom I develop it)
  1. more than a month ago
  2. Bugs
  3. # 4
Accepted Answer Pending Moderation
Hi.
I have no news from the developer.
Do you know if someone is working on this issue ?
  1. more than a month ago
  2. Bugs
  3. # 5
Accepted Answer Pending Moderation
Up ?
  1. more than a month ago
  2. Bugs
  3. # 6
Accepted Answer Pending Moderation
Hi,

I apologise for not replying sooner. I just remind the developer to take a look and reply back. I guess that this ticket fell out of his radar somehow
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 7
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
Hey there Myster Dog :)

At first I was - "wasn't that bug been fixed already" and after looking into the code - yes it is resolved long time ago.

// Use the entered name in the comment
$name = $comment->name;

// If the username is logged in, then use either real or user name
if ($comment->userid)
{
$name = $config->get('layout.use_name', 0) ? $comment->user_realname : $comment->user_username;
}


You said that "use names" is disabled in your settings. Are you using ccomment Core or PRO? In the pro version one is able to change this setting and you would see the user's real names in the comments.

Regards,
Daniel
Attachments (1)
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 8
Accepted Answer Pending Moderation
Hello Daniel.

Thanks for your answer.
I'm using CComment Core.

I've noticed that in comment.json.php :

// If the username is logged in, then use either real or user name
if ($comment->userid)
{
$name = $config->get('layout.use_name', 0) ? $comment->user_realname : $comment->user_username;
}


whereas in comment.php :

if ($comment->userid)
{
if ($config->get('layout.use_name', 1))
{
$json[$key]->name = $comment->user_realname;
}
else
{
$json[$key]->name = $comment->user_username;
}
}


Is it normal to have $config->get('layout.use_name', 1) in comment.php (and not $config->get('layout.use_name', 0) as in comment.json.php) ?
  1. more than a month ago
  2. Bugs
  3. # 9
Accepted Answer Pending Moderation
Hi Daniel.

Did you have some time to look at my issue since my last post ?
  1. more than a month ago
  2. Bugs
  3. # 10
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
what happens if you change it to 0? Is it working as you want it?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 11
Accepted Answer Pending Moderation
Yes.

The bug comes from this little mistake (and that's the reason why I told you to look at this difference).
The error is in components/com_comment/helpers/comment.php on line 84.

I thought you would change it...

If I change it on my side, the error will recur at the next update...
  1. more than a month ago
  2. Bugs
  3. # 12
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
fix added. So you are safe to update that file. Next version will contain the change.

The problem comes from the fact that you are using the core version and the settings in the core version is disabled. So, once you click save - no value is stored for this option. And then since we set the value to 1 there, we end up in the wrong if.

If you were using the pro version you wouldn't run into that because a value of 0 would be stored for the option.

Anyway, now it will work correctly in core as well. Thanks for the help!
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 13
Accepted Answer Pending Moderation
Thanks for your explanation!
Have a nice end of day
  1. more than a month ago
  2. Bugs
  3. # 14
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Last questions

Marker adapted to level of zooming
Hello, I'd like to be able to display a marker showing the number of users on a ...
0 Replies
Posted on Monday, 20 May 2024
Download and install locations from Google
Is there anyway that you can download a list of locations from Google Maps and t...
0 Replies
Posted on Monday, 20 May 2024
Link to maps.google.de in default.php
Hi, i have a question about the default.php under hotspot. i want to integrate...
1 Replies
Posted on Sunday, 19 May 2024
Veranstaltung im Frontend sichtbar obwohl nicht ve
Hallo, folgendes Problem stellt sich mir: Wenn ich eine Veranstaltung dupl...
4 Replies
Posted on Friday, 09 February 2024
Suche bei der Matukio - Fehler Ö Ä Ü..
Hallo, evtl. könnt ihr mir weiterhelfen. Bei mir funktioniert die suche bei ...
3 Replies
Posted on Wednesday, 15 May 2024