1. wimder
  2. Bugs
  3. Wednesday, 30 October 2013
  4.  Subscribe via email
Loading my site through https causes an XMLHttpRequest cannot load ... not allowed by Access-Control-Allow-Origin error.
The reason seems to be the hardcoded the JSON object, in my case http:// in index.php?option=com_comment&task=comments.getcomments&format=json&contentid=62&component=com_content

I've turned of Joomla caching entirely.

Switching to http works fine, but that's not an option.

Is there a solution for this?
Responses (4)
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
Wait a second. As you can see your site is also running through https:
https://compojoom.com/about/blog/entry/cmc-1-4-subscribing-users-to-your-mailchimp-lists-just-got-way-easier
And the form loads just fine and there are no errors. We call the https url to get the comments. How are you turning https on? Is it through the global config or what do you do exactly?

Regards,
Daniel
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 1
Accepted Answer Pending Moderation
Good point Daniel, thanks! https is forced by our UAG. We're in the process of migrating our websites to another hosting platform. I'll try to move the site to see if that might have been be the problem. I'll keep you posted.

Thanks,

Wim
  1. more than a month ago
  2. Bugs
  3. # 2
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
UAG? What is that? Can you set it in the joomla global config?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 3
Accepted Answer Pending Moderation
That's Microsoft Forefront Unified Access Gateway. It has loads of options and makes things more complicated and it's easier to mess stuff up. We're moving to a server which is not behind this gateway anyway. My guess is that this will resolve the cross domain issue as well. I'll let you know next week.
  1. more than a month ago
  2. Bugs
  3. # 4
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Last questions

Registration form Matukio not working
Please help: Matukio registration form does not work - when I press Next/Ďalej/ ...
1 Replies
Posted on Tuesday, 20 September 2022
  • New
  • Issue in displaying map
    Hi I am having and issue with the display of the map. I did all the process wi...
    9 Replies
    Posted on Tuesday, 20 September 2022
  • New
  • Enable push up notification?
    Hi there. I want to enable push up notification for new threads but don’t kno...
    1 Replies
    Posted on Monday, 19 September 2022
  • New
  • Vivawallet PAyment
    Is it possible to integrate Vivawallet payment in Matukio? https://developer....
    0 Replies
    Posted on Sunday, 18 September 2022
  • New
  • Slow web page loading
    Hi I have a question about HotSpot - Mapview. I've uploaded several 36 differen...
    3 Replies
    Posted on Saturday, 28 October 2017
    • #Hotspots
    • #mapview