1. panoman
  2. Bugs
  3. Wednesday, 12 December 2018
  4.  Subscribe via email
Hi guys,
I have a problem with CComment core and that is I've installed version 6.0.6 (latest until now) and set its permissions to allow logged in users to comment but no user can post comments. When trying to post a comment, I get the following error in my browser console:
https://mydomain.com/?option=com_comment&task=comments.getcomments&format=json&lang=en&contentid=32&component=com_content&start=1 (Failed to load resource: the server responded with a status of 403 (Forbidden))
https://mydomain.com/?option=com_comment&task=comment.insert&format=json&86577dce62da6b8ec4875c2c770506e7=1 (Failed to load resource: the server responded with a status of 404 (Not Found)).

My frontend language is Persian(FA) however its mentioned lang=en in the above link, could it be the cause?
Any bits of help is appreciated...
Igor Mihaljko
Hotspots supporter
Accepted Answer Pending Moderation
0
Votes
Undo
Hi,

please edit your first post and under the "Site details" provide your website URL and super admin login details so I can take a look at the issue and see what is the cause of it
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo
Thanks for your reply @Igor Mihaljko and sorry for my delay. I updated the access info and will be glad if you check it.

Thanks
  1. more than a month ago
  2. Bugs
  3. # 2
Igor Mihaljko
Hotspots supporter
Accepted Answer Pending Moderation
0
Votes
Undo
Hi,

can you tell me what kind of caching do you have enabled on the site? Can you disable it?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 3
Accepted Answer Pending Moderation
0
Votes
Undo
on joomla system cache is off. On my host (cpanel) I set Compress Content to disabled. Are there any other settings to modify?
  1. more than a month ago
  2. Bugs
  3. # 4
Igor Mihaljko
Hotspots supporter
Accepted Answer Pending Moderation
0
Votes
Undo
Hi,

can you please provide URL to your website backend? I tried with https://irantoystore.ir/administrator but I am receiving Error 404
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 5
Accepted Answer Pending Moderation
0
Votes
Undo
Hi,
That is: https://irantoystore.ir/administrator/index.php It requires index.php at the end (doesn't require it on frontend but don't know why its required in backend)
  1. more than a month ago
  2. Bugs
  3. # 6
Igor Mihaljko
Hotspots supporter
Accepted Answer Pending Moderation
0
Votes
Undo
Hi,

I have asked our devs to take a look. In the meantime, what happens if you disable RSFirewall temporarily?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 7
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
0
Votes
Undo
I had a look, but I have no clue what's going on there.

The request to fetch the comments goes through fine and returns 0 commetns for your articles - which seems to be correct as you don't have any comments.

When we try to post however joomla responds with invalid token. I had a look at the token we send - it's there. I've seen this only when cache is on, but in your case it is off. Your system plugins seem fine...

Is this a production site? I'm thinking that it could be the hosting company doing something in the middle? Can you try setting up a new joomla website (on this host) and installing only the comment extension there - is it working?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 8
Accepted Answer Pending Moderation
0
Votes
Undo
Dear @Igor Mihaljko and @Daniel Dimitrov, I appreciate your taking time to search for the cause of the error. This is actually a test server on a shared host. We have 7 other productions sites that have the same problem. I attached the Cpanel login details in the first post and would be glad if you take a look at our host panel. Do any changes or tests you might need because as I mentioned this is a test server and a copy of our original site.
  1. more than a month ago
  2. Bugs
  3. # 9
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
0
Votes
Undo
Can you provide me with just ftp. I tried to create my own ftp account , but I get:

Status: Connection established, waiting for welcome message...
Status: Initializing TLS...
Status: Verifying certificate...
Status: TLS connection established.
Status: Logged in
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (xxxxxx)
Command: MLSD
Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing


Please create an ftp account, test that it works with filezilla and I'll have a new look
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 10
Accepted Answer Pending Moderation
0
Votes
Undo
I figured out the reason to this problem finally. It was because of some strange code in htaccess and I really don't know how it was created. it includes multiple rewrite conditions:

# Block any script trying to base64_encode data within the URL.
# Block any script that includes a <script> tag in URL.
# Block any script trying to set a PHP GLOBALS variable via URL.
# Block any script trying to modify a _REQUEST variable via URL.
# Return 403 Forbidden header and show the content of the root home page
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge/[0-9a-zA-Z_-]+$
RewriteRule .* index.php [F]
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
# and the requested path and file doesn't directly match a physical file
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge/[0-9a-zA-Z_-]+$
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
# internally rewrite the request to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge/[0-9a-zA-Z_-]+$
RewriteRule .* index.php [L]


I changed my htaccess with the simple one made by Joomla and its working now. Thank you for your following this matter.
  1. more than a month ago
  2. Bugs
  3. # 11
Igor Mihaljko
Hotspots supporter
Accepted Answer Pending Moderation
0
Votes
Undo
Hi,

thank you for the information. I am glad that you managed to solve the issue
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 12
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
0
Votes
Undo
thanks for the feedback. Those rewrite rule seem to be there for your hzttps certificate from comodo or letsencrypt. Don't know why they are added though in the .htaccess.
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 13
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Last questions

Gestaffelte Gebühren werden im Export nicht angeze
Hallo Auf meiner Seite habe ich 4 verschiedene Events. Bei 2 habe ich individue...
6 Replies
Posted on Tuesday, 15 October 2019
  • New
  • Ccomment is resulting in: Call to a member functio
    I recently completed upgrading our servers to PHP 7.2.20 and was informed this m...
    0 Replies
    Posted on Monday, 21 October 2019
  • New
    • #CComment 6
    Integration with other components
    Hello. How can I integrate CComment with Joomla component(it hasn't been integra...
    0 Replies
    Posted on Monday, 21 October 2019
  • New
  • Double escaping that creates problems from French
    Double escaping that creates problems from French language file. Check attached ...
    0 Replies
    Posted on Monday, 21 October 2019
  • New
    • #bug
    • #language
    Email template missing details
    For some reason, my event booking email to the customer is not including ticket ...
    4 Replies
    Posted on Thursday, 17 October 2019
  • New