1. Step
  2. Bugs
  3. Sunday, 24 October 2021
  4.  Subscribe via email
Hi,
I'm using Joomla 3.10.2 and the mailchimp Newsletter-Plugin Version 4.1.2 .
For some reason there is a error message, that appears after new subscriptions:

"400: test4@stephxxxxrk.de is already a list member. Use PUT to insert or update list members."

Updates of users work just fine.

What am I supposed to do to fix it?

Greets
Stephan
Responses (5)
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
Have you synced your list before using the plugin?

It appears that the email you try to subscribe is already a member in the list, but since the list is not synced locally we try to subscribe that user again instead of updating his subscription.
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 1
Accepted Answer Pending Moderation
I did a sync now, but the error still shows while adding new, unknown mailadresses.

More ideas?

Thx
Stephan
  1. more than a month ago
  2. Bugs
  3. # 2
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
Wait, if you are testing with unknown mail addresses why are you getting "address is already in the list"?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 3
Accepted Answer Pending Moderation
This is exactly my question/problem!
Why am I getting this message with new, unknown mailadresses?

(Please look at the URL in the Site Details to try it)
  1. more than a month ago
  2. Bugs
  3. # 4
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
Hi there,

It actually appears to be working right, but the message is wrong. I did receive a "subscribe to newsletter" email. Right below the "400 error", there was a success message.

Also the network request we did returned a success. So it must be something in the display.

Did you make any modifications to the module? A template override or something?

I also see that there is a javascript error in the minified jch file. Can you try disabling jch and checking whether this resolves the issue?

Regards,
Daniel
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 5
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Last questions

Submission form doesn't send data to database or w
I don't know if this is a bug, but the submission form all of a sudden, maybe af...
8 Replies
Posted on Monday, 23 January 2023
  • New
    • #custom fields
    • #submission form,
    ccomment issue on mobile devices
    Hello I installed your Ccomment component, but I noticed that it has a bug in m...
    1 Replies
    Posted on Friday, 27 January 2023
  • New
  • plötzlich alles in englisch
    seit ein paar Tagen ist bei mir das ganze Matukio auf englisch. Ich hab keine A...
    2 Replies
    Posted on Saturday, 28 January 2023
  • New
  • migrate freezes after moving 56 out of 220 article
    Hello, CMigrator migrate function is freezing after moving 56 articles from t...
    0 Replies
    Posted on Saturday, 28 January 2023
  • New
  • zusätzliche Buchungsfelder in Teilnehmerliste bei
    Hallo liebes Entwicklerteam, ich komme mal wieder nicht weiter bei meinem Probl...
    6 Replies
    Posted on Saturday, 21 January 2023