1. Joerg
  2. CTransifex
  3. Wednesday, 22 June 2016
  4.  Subscribe via email
Hi,
I tried to install ctransifex on Joomla 3.5.1 and afterwards also tried with Joomla 3.4.8. Installation works, but after installation and configuration I'm unable to pull the language packs from Transifex. The popup window holding the 'Get data' buttons remains empty/ does not open. I did ask somebody else to test that and he encountered the same issue. Don't see any error messages in Joomla Debug and in the browser. No errors in the log files either.
Responses (7)
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
I just tested it on our site and it works.

Is the window opening or not opening? Can I see a screenshot. Also try to set error reporting in global config to none. It's possible that you have a warning that kills the ajax request.

Regards,
Daniel
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. CTransifex
  3. # 1
Accepted Answer Pending Moderation
I just tested it on our site and it works.

Hi again,
Setting error reporting to 'None' didn't make a difference. I might have two different issues when trying to use ctransifex with Joomla 3.5.1. If I change from the Isis template to the Hathor template, I can at least see the modal window.
Below are some screenshots.

With Joomla 2.5.28 I don't have these problems.

Regards
Joerg
  1. more than a month ago
  2. CTransifex
  3. # 2
Accepted Answer Pending Moderation
I experienced exact same issue on a fresh Joomla! 3.6.5 installation with CTransifex 1.5.
Setting error reporting to 'none' doesn't help.
I can provide site admin access if you prefer to look at it.
  1. more than a month ago
  2. CTransifex
  3. # 3
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
I'll have to look at what we are distributing as a download package, but I just tested CTransifex on our site and it works as expected. The modal opens, the ajax requests are working and they are generating the packages. So I'm not really sure why are you running in all those issues, but it's possible that I've fixed something for us in the past and have fogotten to release a new package.

Regards,
Daniel
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. CTransifex
  3. # 4
Accepted Answer Pending Moderation
Hi Daniel,

I can confirm that in a fresh new Joomla 3.6 installation I only get data if I have harbor template on, with Isis I get a translucent page and nothing.

Thanks
  1. more than a month ago
  2. CTransifex
  3. # 5
Accepted Answer Pending Moderation
but it's possible that I've fixed something for us in the past and have fogotten to release a new package.


maybe its this fix the solution?
https://github.com/JoomliC/ctransifex/commit/c34c96d810c26cda06b0e234c05a94b29d507d98#diff-0

Update: it worked for me: Joomla 3.7 / Isis template / Chrome
(Firefox is not fixed yet)
  1. more than a month ago
  2. CTransifex
  3. # 6
Accepted Answer Pending Moderation
Hi Paulo nice to hear you again.

Yess. I can confirm fix is working on Joomla! 3.6.5 with both Chrome and Firefox (after clearing browser's cache). No problem after upgrading Joomla! 3.7.0 also.

Get data dialog opens and process completed
(But there was no zip file created. I use same server and CTransifex configuration with Joomla! 2.5.28 version which is working good. Anyway it's another issue and I will check later).

Thanks
Kaya

Update1: I used to latest CTransifex package with fresh Joomla! installation but it seems like github files are different from release package (at least css files). Maybe you need to look at it and pull the latest release again.

Update2: I found that zip file creation problem reincarnation of 'JFile class not found in package.php' issue in this topic.

That topic has some information but Paulo's previous - jimport('joomla.filesystem.file'); - suggestion is not in files as Daniel mentioned.
I tried same fix without success and found another fix, seems like working:
- Open administrator/components/com_ctransifex/helpers/package.php file
- Find defined('_JEXEC') or die('Restricted access');
- Add these code after

/* Joomla doesn't autoload JFile and JFolder */
JLoader::register('JFile', JPATH_LIBRARIES . '/joomla/filesystem/file.php');
JLoader::register('JFolder', JPATH_LIBRARIES . '/joomla/filesystem/folder.php');

Update 3: Project delete button not working.
On Joomla! 3.7.0 Project delete button shows a dialog "project.delete, OK Cancel" and when I hit the button nothing happens.

I found some suggestion on similar problem that I need to add 'message text' to JToolBarHelper function. First I added 'Are you sure?' message without success.
After I read this document and changed 'project' as 'projects' it started to work miraculously.

So in administrator/components/com_ctransifex/views/projects/view.html.php
changed this line: JToolBarHelper::deleteList('project.delete');
into this: JToolBarHelper::deleteList('Are you sure?','projects.delete');

I didn't touch project.add and project.edit buttons because they are both functioning normally.

CTransifex seems like suffering with Joomla! 3.x versions and needs some overhaul.
  1. more than a month ago
  2. CTransifex
  3. # 7
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Last questions

2 x Bugs after J4 Migration
Hi. I had my site upgraded to J4 (http://www.mygbhousing.info). When I went to c...
1 Replies
Posted on Tuesday, 29 November 2022
  • New
  • pro Person* entfernen
    Guten Tag, gibt es eine Möglichkeit den * bei "pro Person zu entfernen auch...
    0 Replies
    Posted on Tuesday, 29 November 2022
  • New
  • Jomsocial Integration?
    Ok so i now have the PRO version and its installed. I have chosen the Jomsoci...
    1 Replies
    Posted on Monday, 28 November 2022
  • New
    • #JomSocial
    Weather
    Dear compojoom team, I have noticed that the weather you want to see on googl...
    5 Replies
    Posted on Wednesday, 14 February 2018
    Installed PRO over the free version, but not seein
    Hi, I had the free version last week, and today I bought the PRO subscription...
    2 Replies
    Posted on Monday, 28 November 2022
  • Resolved
  • New
    • #JomSocial