1. Martien van Ee
  2. Bugs
  3. Thursday, 02 April 2020
  4.  Subscribe via email
I installed Ccomment core on a clean Joomla setup on XAMPP for Windows.
It works fine, but only works in english. If I switch to a different language, the comment form will not show up, but 'powered bij ccomment' is visible.
I tried German, French and Dutch, but Ccomment does not seem to pick up the language files.
Any ideas?
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
0
Votes
Undo
Well, go to global config. Enable debug language and then look at the output in the frontend. Do you have any errors in the language files?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo
I think the problem is with the file JROOT\language\en-GB\en-GB.lib_compojoom.ini.
It is loaded with the UK English version, but not with other languages. It does not exist in a translated version, which means that usually the english version is loaded, but that does not seem to happen.
See dump of loaded ini files on the next page.
There are no translation errors
  1. more than a month ago
  2. Bugs
  3. # 2
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
0
Votes
Undo
lib_compojoom shouldn't be the problem as the ccomment strings seem to be loaded. Are there any langauge errors output in the debugger?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 3
Accepted Answer Pending Moderation
0
Votes
Undo
No. There are no translation errors or missing string messages. I spent a few hours trying to find anything, and the only thing I could find is that the main comments form is simply not loaded at all (I compared the html output of the english version with the dutch/french/german output.)
  1. more than a month ago
  2. Bugs
  3. # 4
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
0
Votes
Undo
if you look at the nl version of com_comment.ini - is it in dutch?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 5
Accepted Answer Pending Moderation
0
Votes
Undo
The language files contents are in the correct language.
  1. more than a month ago
  2. Bugs
  3. # 6
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
0
Votes
Undo
I'm out of ideas. I'll need to debug on your site. For this please provide me with access credentials.

Regards,
Daniel
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 7
Accepted Answer Pending Moderation
0
Votes
Undo
That is not possible because it is on my local laptop.
I have already solved it by using a forum solution instead, as it is only meant for a very temporary project (yes, caused by the Corona virus), and not for a production type environment.
I am quite sure that it is a problem caused by a specific version combination of PHP, Joomla and ccomment, as I have not had this problem before.

Thanks for assisting me. Really appreciated!
  1. more than a month ago
  2. Bugs
  3. # 8
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
0
Votes
Undo
All right. Thanks for letting me know!
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 9
Accepted Answer Pending Moderation
0
Votes
Undo
Just wanted to confirm that it was indeed a combination of server side versions of PHP etc.
Just did a new install on a different server and had no problems at all. PHP 7.3.16, joomla 3.9.18 works fine.
  1. more than a month ago
  2. Bugs
  3. # 10
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Last questions

Not able to send comment
Hello, I'm not able to confirm comments. Website in attachment. Thanks. ...
5 Replies
Posted on Tuesday, 08 September 2020
Need map shown in module
I need the map shown in a module because i've a template builder. A menu item i...
1 Replies
Posted on Tuesday, 22 September 2020
  • New
    • #module
    Matukio Events Checkbox
    Hallo, ich habe im Standard-Buchungsformular Checkboxen für Datenschutz etc. ei...
    0 Replies
    Posted on Thursday, 24 September 2020
  • New
    • #layout, checkboxes
    Rights to delete comments in the backend?
    Hi! Is it only possible for Super Admins to delete comments from the backend of ...
    0 Replies
    Posted on Wednesday, 23 September 2020
  • New
    • #Rights
    • #CComment 6
    Description not appearing on webpage and in an ema
    Good Day, For some events that my client creates, the description will app...
    2 Replies
    Posted on Monday, 21 September 2020
  • New