1. Martien van Ee
  2. Bugs
  3. Thursday, 02 April 2020
  4.  Subscribe via email
I installed Ccomment core on a clean Joomla setup on XAMPP for Windows.
It works fine, but only works in english. If I switch to a different language, the comment form will not show up, but 'powered bij ccomment' is visible.
I tried German, French and Dutch, but Ccomment does not seem to pick up the language files.
Any ideas?
Responses (10)
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
Well, go to global config. Enable debug language and then look at the output in the frontend. Do you have any errors in the language files?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 1
Accepted Answer Pending Moderation
I think the problem is with the file JROOT\language\en-GB\en-GB.lib_compojoom.ini.
It is loaded with the UK English version, but not with other languages. It does not exist in a translated version, which means that usually the english version is loaded, but that does not seem to happen.
See dump of loaded ini files on the next page.
There are no translation errors
  1. more than a month ago
  2. Bugs
  3. # 2
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
lib_compojoom shouldn't be the problem as the ccomment strings seem to be loaded. Are there any langauge errors output in the debugger?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 3
Accepted Answer Pending Moderation
No. There are no translation errors or missing string messages. I spent a few hours trying to find anything, and the only thing I could find is that the main comments form is simply not loaded at all (I compared the html output of the english version with the dutch/french/german output.)
  1. more than a month ago
  2. Bugs
  3. # 4
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
if you look at the nl version of com_comment.ini - is it in dutch?
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 5
Accepted Answer Pending Moderation
The language files contents are in the correct language.
  1. more than a month ago
  2. Bugs
  3. # 6
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
I'm out of ideas. I'll need to debug on your site. For this please provide me with access credentials.

Regards,
Daniel
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 7
Accepted Answer Pending Moderation
That is not possible because it is on my local laptop.
I have already solved it by using a forum solution instead, as it is only meant for a very temporary project (yes, caused by the Corona virus), and not for a production type environment.
I am quite sure that it is a problem caused by a specific version combination of PHP, Joomla and ccomment, as I have not had this problem before.

Thanks for assisting me. Really appreciated!
  1. more than a month ago
  2. Bugs
  3. # 8
Daniel Dimitrov
Support team
Accepted Answer Pending Moderation
All right. Thanks for letting me know!
Please if you use our extensions be so kind and review them at JED
Matukio | Hotspots Pro | CComment Pro
  1. more than a month ago
  2. Bugs
  3. # 9
Accepted Answer Pending Moderation
Just wanted to confirm that it was indeed a combination of server side versions of PHP etc.
Just did a new install on a different server and had no problems at all. PHP 7.3.16, joomla 3.9.18 works fine.
  1. more than a month ago
  2. Bugs
  3. # 10
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Last questions

Slow web page loading
Hi I have a question about HotSpot - Mapview. I've uploaded several 36 differen...
4 Replies
Posted on Saturday, 28 October 2017
  • #Hotspots
  • #mapview
Page Navigation!
The admin bar is currently on top before site visitors see the comments. How can...
0 Replies
Posted on Wednesday, 25 May 2022
  • New
  • Exporting Markers and Importing via PHPMyAdmin
    This is not a question, unless someone reading this knows a better way to do thi...
    3 Replies
    Posted on Monday, 22 July 2019
    • #Export
    • #import
    • #phpmyadmin
    • #markers
    Show all markers (and keep paginated list)?
    For my particular use case it makes more sense to do marker clusters than tiles....
    1 Replies
    Posted on Thursday, 19 May 2022
    Two message dialogs when submitting hotspot
    Hi! I noticed that there are two Joomla messages shown when a hotspot is subm...
    1 Replies
    Posted on Thursday, 05 May 2022