×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: error

error 5 years 2 days ago #22311

  • Jon Burdon
  • Jon Burdon's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
I'm using Joomla 3 (latest version) and not sure if I want to use this extension on my site. I need to create a category before I create locations (I think.) I get the following error when I try to save a category:

Fatal error: Class 'JFile' not found in /home/planet85/public_html/freedomtorun.co.uk/administrator/components/com_hotspots/controllers/category.php on line 227

Any ideas?

error 4 years 11 months ago #22341

  • Jorge Alves
  • Jorge Alves's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Same error here.
There a line commented in that file, but I could not find what was the problem...

error 4 years 11 months ago #22342

  • Jorge Alves
  • Jorge Alves's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
The error is related to image/icon option.
It seems it lacks the inclusion of a config file

error 4 years 11 months ago #22343

  • Jorge Alves
  • Jorge Alves's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
I added this lie to the category.php

jimport('joomla.filesystem.file');


and it worked....
not sure if this is the right procedure.
will wait to get confirmation...

error 4 years 11 months ago #22360

  • Yves Hoppe
  • Yves Hoppe's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 3519
  • Karma: 70
  • Thank you received: 556
Hi Jorge,

sorry for the late response - Daniel (the hotspots developer) is currently on vacation, but i am going to help you as far much as i can.

Joomla 3.1.4 and 3.1.5 have a known Camel-Case bug which caused many extensions to stop working - Daniel included a workaround in the latest development version.

Yves

error 4 years 11 months ago #22405

  • Jorge Alves
  • Jorge Alves's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
it seems everytime there is a file upload you have to include that line in the .php

Looking forward to see this fixed.

error 4 years 11 months ago #22406

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
This should be fixed now in 3.5.4

Regards,
Daniel
The following user(s) said Thank You: Jorge Alves
  • Page:
  • 1
Time to create page: 0.085 seconds