×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: coments not showing by default

coments not showing by default 7 years 1 month ago #23886

  • Robert Grimes
  • Robert Grimes's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Just installed latest release of CComments. I want the comments to show automatically. All I have is the button to write a comment with the number of comments. If I click on it, I get the comments and the editor to add a new one. Here is what I see

coments not showing by default 7 years 1 month ago #23888

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Robert,
So what do you actually expect to happen?

coments not showing by default 7 years 1 month ago #23891

  • Robert Grimes
  • Robert Grimes's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
I expected the comments to be shown when the page is first presented and not to have the user click to see them.

coments not showing by default 7 years 1 month ago #23903

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
In joomla each extension has several views. The view that you are refering to is the list view for com_content. In this view users see a "write comment" button, when they click on it, they go to single view of com_content. There you have the form of comments. It is the way nearly 99% of the web works. When you go to magazine site, they have a list with their articles and when you read a single one, below it you can find the comment form.

Kind regards,
Daniel

coments not showing by default 7 years 4 weeks ago #24127

  • Robert Grimes
  • Robert Grimes's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Let me try to explain again what I am trying to do.

Here is what the user sees when they enter my page: (Comments are not show)


What I want to user to see when they enter the page, without any action on their part is: (Comments are shown)


Any suggestions how to show all the comments by default?

coments not showing by default 7 years 3 weeks ago #24130

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
You'll need to change the view that leads to this article. Go to your menu settings -> click on the menu item in question -> and then set it instead of list view to be single view. Then when the user clicks on the button he would see the comment form.

Regards,
Daniel

coments not showing by default 7 years 3 weeks ago #24133

  • Robert Grimes
  • Robert Grimes's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
I am new to Joomla, but I think I see what is going on. I am not sure if I stated that I am trying to have multiple articles on one page which lead me to having a blog layout rather than single article layout. I am thinking that you are explaining a solution for single article layout which I verified as working as you state. However, that limits me. But, I changed my thinking on the blog layout and put a read more break in the article and then the page shows all the comments when looking at all the article.

Your advice lead me to the solution, it just took and extra step in my thinking to get there.
  • Page:
  • 1
Time to create page: 0.282 seconds