×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Transifex replied with: false

Transifex replied with: false 2 years 5 months ago #31497

  • Dmitry Rekun
  • Dmitry Rekun's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Hello and thank you for your component.

I am trying to use it for the first time, but with no success. I've setup my first project and want to get data from Transifex. But it always fails :( The message I have is:

Transifex replied with: false


I double checked my username and password in Options, but still nothing... I've attached my project settings screenshot. I am using Joomla! 3.4.1

Attachments:

Transifex replied with: false 2 years 5 months ago #31503

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Are you sure that you've provided a correct username and password in the options?

Transifex replied with: false 2 years 5 months ago #31504

  • Dmitry Rekun
  • Dmitry Rekun's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Daniel, sure. I am rechecked it several times. I also tried to write in the notepad and paste. So I am sure that it is correct.
How can I trace the error from Transifex? There should be some more descriptive message from Transifex, I thnk :)

Transifex replied with: false 2 years 5 months ago #31505

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
I haven't looked at the extension for some time now. I would trace in the getData function in the transifex.php helper:
administrator\components\com_ctransifex\helpers\transifex.php

I think that all calls that I make to transifex go through the getData function. Is curl enabled on your server actually?

Regards,
Daniel

Transifex replied with: false 2 years 5 months ago #31507

  • Dmitry Rekun
  • Dmitry Rekun's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Yes, cURL is enabled.

Ok , you are right it is in getData() . I will try to trace :side:

Transifex replied with: false 2 years 5 months ago #31513

  • Dmitry Rekun
  • Dmitry Rekun's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Well that's my sever problem. The error message I have is:

Curl error: Problem with the SSL CA cert (path? access rights?)


Thanks once again for help. Will try to fix my server :P

Transifex replied with: false 2 years 5 months ago #31516

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
I should update the getData function to actually use Joomla's http class. When i wrote the extension there was an issue with curl under joomla 2.5 and I decided to use default curl. But since in the next version i'm only going to support joomla 3....
If you want you can make the change - the code is on github.

Cheers,
Daniel

Transifex replied with: false 2 years 5 months ago #31517

  • Dmitry Rekun
  • Dmitry Rekun's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Daniel, the problem is still there in Joomla 3. I recently faced it with my own extension - you can not set cURL options if you are using Joomla's Http class. See this pull:
github.com/joomla-framework/http/pull/12

When it will be backported to the CMS you can use Http class then ;) Thanks to Michael Babker who pointed me to this issue.

Transifex replied with: false 2 years 5 months ago #31521

  • Dmitry Rekun
  • Dmitry Rekun's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Thanks, this can be closed. I've fixed my problem with SSL.
  • Page:
  • 1
Time to create page: 0.170 seconds