×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Joomla User Managment Deletes CMC Email

Joomla User Managment Deletes CMC Email 5 years 1 month ago #35158

  • NEP
  • NEP's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
Having a very odd issue with CMC. So, a user registers to my site and all the information get put into both CMC and Joomla's core users. When an admin goes to edit or enable a user using Joomla's Manage User, and slicks save, the email under CMC/Mailchimp form gets removed entirely. It is also removed in CMC since it is synced with Joomla. The first image is before the user it edited. The second is it after being saved.




I'm not sure if this is a problem with CMC or not. I noticed there are tabs in Joomla's Manage Users for CMC (Newsletter, Newsletter Information, etc), so it has something to do with CMC. I've tried many things, but nothing keeps it from. Is there a fix for this I'm not thinking of?

Joomla User Managment Deletes CMC Email 5 years 1 month ago #35163

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey there,

I'll have to ask mailchimp about that. Maybe it is an update issue. In the past we were working with API v1.3 and now we are using api v3. And it seems that the emial field is no longer part of the merges array that we send and get back from mailchimp.

I looked at what's going on. And basically - when you save a user we have the email address and we do send the updated information to mailchimp. Then we need to update our local database -> so we request the data that mailchimp has on this subscriber and we save this in the database. Everything is fine, except that the returned data from mailchimp no longer has the EMAIL merge field. And since we don't have this stored in the database, when we render the form we display no email address for the user, despite the fact that in the email field we have the correct user id. Have you actually configured any field mappings? This way you won't have to display the email field at all.

Regards,
Daniel
  • Page:
  • 1
Time to create page: 0.113 seconds