×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Built-in Captcha not working properly

Built-in Captcha not working properly 2 years 10 months ago #29508

  • Mark Krell
  • Mark Krell's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
I have the latest versions of Joomla and CComment. I have tried every configuration possible of Public->Guest->Manager->...Super User. If I set the built-in Captcha to "Guest", I can still post without logging in, and without Captcha.
If I set Captcha to Public, every level has to use Captcha when posting.

If I set all levels, Guest to Super User, to posting permission except for Public, I get the "You are not authorized to post a comment" message when not logged in. So I cannot even post as "Guest". Guest is like something that does not exist.

The only other thing I can think of doing is requiring "Guest" to register. Then, "Guest" is no longer "Guest" but, "Registered".

I read through "Show captcha only for guests?" compojoom.com/support/documentation/ccomment/ch05s04 , and it does not work. The hotlink within the article, "This tutorial", goes nowhere and Produces a page with this message: "How do you hide something from logged in users There is currently no text in this page. You can search for this page title in other pages, or search the related logs, but you do not have permission to create this page." I have spent the entire day searching links and forums for a solution and this is my last resort.

At this point it appears that CComment will not work with captcha unless captcha is required for all levels. If this is not true, then how can the problem be corrected?

Built-in Captcha not working properly 2 years 10 months ago #29509

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hey Mark,
So what is exactly the issue? You see the captcha and you can post even without filling it out? Or you don't see the captcha at all?
I just tested it and it works for me. Here is the link to the post:
docs.joomla.org/How_do_you_hide_somethin...m_logged_in_users%3F

On joomla 3 -> you have to navigate to the user groups -> click on options -> then under "Guest user group" set guest. In my case it was set to "public".

Also note that - if you were already browsing your site as non-logged in user when you made the above change -> your session is still active. And your user group won't automatically change to guest. You'll have to either wait for your session to expire or delete your session or use another browser to view the page. Then you should see the captcha under the comment form.

Regards,
Daniel

Built-in Captcha not working properly 2 years 10 months ago #29512

  • Mark Krell
  • Mark Krell's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Greetings Daniel,

Set up is done on my desktop computer. Browser is pulled up on my laptop. IE and Firefox are both being used on laptop. (1) History is purged from both browsers, (2) browsers are closed, (3) browsers are selected again. This is done with each change I have made. I will do it again this morning to take screen shots and show you the results.

When “all” are Authorised to post; “all” are set to Autopublish; and Captcha is set to “Guest” only (Image 001):


[/color]No Captcha appears. No moderation message appears (Image 001b).


When “all” are Authorised to post; “guest” is NOT set to Autopublish; and Captcha is set to “Guest” only (Image 002):


No Captcha appears. No moderation message appears (Image 002b).


When “guest” is NOT set to Authorised to post; “guest” is NOT set to Autopublish; and Captcha is set to “Guest” only (Image 003):


[/color] No Captcha appears. No moderation message appears (Image 003b).


When “public” is NOT Authorised to post; “all” are set to Autopublish; and Captcha is set to “Guest” only (Image 004):


Cont'd

Built-in Captcha not working properly 2 years 10 months ago #29513

  • Mark Krell
  • Mark Krell's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Only the message appears: “You are not authorized to post comments” (Image 004b)


When “all” are set to Authorised to post; “public” is NOT set to Autopublish; and Captcha is set to “Guest” only (Image 005):


[/color]Only the message appears: “Comments will undergo moderation before they get published” (Image 005b)


When “all” are set to Authorised to post; “public” is NOT set to Autopublish; and Captcha is set to “Public” only (Image 006):


[/color]The Captcha appears, and the message appears: “Comments will undergo moderation before they get published” (Image 006b);


[/color] Logging in as “Supper User”:
The Captcha appears, and no system messages appear (Image 006C)


Thank You,
Mark

Built-in Captcha not working properly 2 years 10 months ago #29519

  • Mark Krell
  • Mark Krell's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Hello Daniel,

Please hit me in the head with a tire iron :woohoo:

It is wise to back track through one's site/system to look at and verify all the global settings before venturing off looking through CSS3, bootstrap, and template coding. I could have saved myself quite a few hours of banging my head against the wall.

When I came back to look at the posts and images I left earlier today, the light bulb flickered. Sure enough, the problem was a very minor issue in that I didn't have the relationship and permissions set up properly between "public" and "guest.

I fired it up on the laptop with Firefox and all works as it should be. Oddly, it is still not working in IE. But I will check it as soon as I get up in the morning.

Thank you,
Mark
  • Page:
  • 1
Time to create page: 0.787 seconds