×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Language not working

Language not working 7 years 5 months ago #27652

  • Poul Theodorsen
  • Poul Theodorsen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
I just installed CComments and it seems to be working perfectly. I would like to buy the pro version, but I need to be sure that I can solve this problem.
I have downloaded and installed the danish language file. I have made sure that both my articles and menu items are set to Danish, but the texts remains to be in english.
I then tried to make a change in the english language file, and this showed up on my page rightaway.

So the problem is that I can't make CComment use the danish language file even though everythiing is set to danish, which is the default language of the whole site . :sick:

Language not working 7 years 4 months ago #27670

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Poul,
I had a look at the danish language files:
compojoom.com/downloads/languages-cool-geil/ccomment/da-DK

The problem is - as you can see the danish translation is only 36% complete. Most of the backend and frontend translations are missing. In addition to this, our configuration is set to only include language files that are 100% translated in the pack (only exeption is for the frontend -> it is set to 50%). So in the language pack that you've downloaded you have a single file -> the one for the frontend and it has few things translated, but not everything. Are you really sure that everything is in english. There must be few strings in Danish.

If you want to help with the translation that would be great! You can join the danish language team and than you can translate the files directly on transifex and they will get automatically updated on our site.

Kind regards,
Daniel

Language not working 7 years 4 months ago #27674

  • Poul Theodorsen
  • Poul Theodorsen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Hi Daniel

You are right that part of the translation is ok. I tried to make change in the danish file for some text that is actually is shown in danish and it works.

I suppose that what the program does is this: first look in the danish language file for the variable xxx. If it exist in the file, then the danish text is shown. If not found, it defaults to english.
Is that how it works?

My problem then is mainly that the text in the submission form is still in english. In the danish language file I found the line containing
COM_COMMENT_LEAVE_COMMENT which was in english and translated it to danish - but it still show up in english.

My problem may be that I need to find the relevant variable names in the english file and copy them to the danish file and translat them?

Language not working 7 years 4 months ago #27675

  • Poul Theodorsen
  • Poul Theodorsen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
HAHAHA - I just found out that the variable was commented out with a ";", so it takes the english variable instead.

Now I can change the texts - after uncommenting them. :lol:

I'd like to help with translation. Only am I very busy right now. I'll see what I can do.

BTW : I am not sure where the text showing the age of a post comes from? Because the danish translation has a very annoying spelling error. The text "Less that a minute ago" is translated to "mindre en et minut" ..... a "d" is missing- it should be "mindre end et minut".

Thank you for your help
  • Page:
  • 1
Time to create page: 0.163 seconds