×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: 500 Server Error for Registered Users

500 Server Error for Registered Users 11 years 8 months ago #9065

  • Greg
  • Greg's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Hi,
I'm on Joomla 1.5.15, PHP 5.26, JoomlaComment 4.0 RC1, mysql 5.0.75.

My new installation of JoomlaComment is only set to appear on certain pages and be commentable by registered users.

When one is not logged in, the page in question appears fine and displays the "Only Registered Users Can write comments" message.

But once I sign in, that same page displays a 500 Server Error.

I've turned off Joomla's built in SEF facility.

Does this point to any likely problem?

I've searched the forum but don't see other cases like this.

Thanks for any help.
Greg

500 Server Error for Registered Users 11 years 8 months ago #9067

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
that is strange. Did you look in the server error log for more information?

500 Server Error for Registered Users 11 years 8 months ago #9069

  • Greg
  • Greg's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Yikes, that was an obvious answer. Nonetheless, I hadn't thought of it. :blush:
It turns out my host doesn't enable logs by default. I've enabled them, and will check this out after they become available and report back.
Thanks,
Greg

500 Server Error for Registered Users 11 years 8 months ago #9070

  • Greg
  • Greg's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
The results are in and I still don't get it!

The error message that gets logged when I try to hit the commentable page while logged in is:
Premature end of script headers: index.php, referer: http://

I've opened up the permissions to 777 for all of the files and folders in the components/com_comment directory.

I've turned off Captcha and nothing changes.

I disabled as many modules for that page as I think I can get away with but, still it doesn't work.

Where might I look next.

Thanks for your help.
Greg

500 Server Error for Registered Users 11 years 8 months ago #9071

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
Do you have a link?
And perhaps a test account I can view from?

500 Server Error for Registered Users 11 years 7 months ago #9118

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
777 is always a bad choice. Please refer to the other captcha threads here in the forum - there you will find the right permissions for the folders and files of joomlacomment.

500 Server Error for Registered Users 11 years 7 months ago #9125

  • Greg
  • Greg's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
You're very right, thank you.
The site is not public yet but, still I should reverse those permissions before I forget.

500 Server Error for Registered Users 11 years 7 months ago #9141

  • JonusC
  • JonusC's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 785
  • Thank you received: 48
Yes, 775 for directories and 644 for folders. Anything higher will purposely throw a 500 error because your site is at a security risk.

But the error "Premature end[...]" also suggests a resource problem. If correct permissions do not resolve it then please study your CPU and Memory usage, and also ensure the node distribution is not near the limit.

500 Server Error for Registered Users 11 years 7 months ago #9150

  • Greg
  • Greg's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
I'm not sure I have access to those on my shared hosting system but, I will at least ask the host to check it out.
Thanks again everyone!
-Greg
  • Page:
  • 1
Time to create page: 0.138 seconds