×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Zero Reply? I think the squid is swimming too deep... LMAO

Zero Reply? I think the squid is swimming too deep... LMAO 9 years 10 months ago #7790

  • chomz
  • chomz's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
on my first time installing !Joomlacomment, and i got this when clicking / accessing article page from front end :

ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: mywebsite.com/index.php ?

The following error was encountered:

* Zero Sized Reply

Squid did not receive any data for this request.

Your cache administrator is webmaster.
Generated Mon, 09 Nov 2009 03:12:32 GMT by webhost.org (squid/2.7.STABLE7)



then i tried to uninstall (full), i could access the single article page again.

i do wanna use this great feature :dry:
i installed it again, and i received that page again ....
any suggestion? :woohoo:

Zero Reply? I think the squid is swimming too deep... LMAO 9 years 10 months ago #7791

  • chomz
  • chomz's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
oh, and when i tried to disable the !Joomlacomment plug in, i could access the single article again but (ofcourse) no one could put any comments :(

help....

Zero Reply? I think the squid is swimming too deep... LMAO 9 years 10 months ago #7793

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
what is squid?

Zero Reply? I think the squid is swimming too deep... LMAO 9 years 10 months ago #7795

  • chomz
  • chomz's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
uhmm.. dunno, i dont understand either.. whenever i enable the !joomlacomment plug in, and i access article from frontend, the page went blank and that page appears :(

Zero Reply? I think the squid is swimming too deep... LMAO 9 years 10 months ago #7796

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
www.google.de/search?as_q=Squid+did+not+..._rights=&safe=images

check the error.log for more information. Perhaps you don't have anymore memory?

Zero Reply? I think the squid is swimming too deep... LMAO 9 years 10 months ago #7812

  • JonusC
  • JonusC's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 785
  • Thank you received: 48
Squid is a proxy server used by many Webhosts for a very cheap way of using Shared User Accounts on one machine.

Put simply, it's a problem with the server. Joomla is not 100% compatible with it, they have tried as hard to make Joomla 1.5 better with Shared Hosts but they are still not perfect yet.

A Google search doesn't have any clear solutions that you could try. But take a look yourself of course: www.google.com/search?q=Joomla+Squid+"zero+sized+reply "

Here's info from the official Squid docs that may be of interest to you, your webmaster, and would be useful to forward to your ISP support staff:

This happens when Squid makes a TCP connection to an origin server, but for some reason, the connection is closed before Squid reads any data. Depending on various factors, Squid may be able to retry the request again. If you see the ``Zero Sized Reply'' error message, it means that Squid was unable to retry, or that all retry attempts also failed.

What causes a connection to close prematurely? It could be a number of things, including:

1. An overloaded origin server.
2. TCP implementation/interoperability bugs. See the System-Dependent Weirdnesses section for details.
3. Race conditions with HTTP persistent connections.
4. Buggy or misconfigured NAT boxes, firewalls, and load-balancers.
5. Denial of service attacks.
6. Utilizing TCP blackholing on FreeBSD.

You may be able to use tcpdump to track down and observe the problem.

Some users believe the problem is caused by very large cookies. One user reports that his Zero Sized Reply problem went away when he told Internet Explorer to not accept third-party cookies.

Here are some things you can try to reduce the occurance of the Zero Sized Reply error:

1. Delete or rename your cookie file and configure your browser to prompt you before accepting any new cookies.
2. Disable HTTP persistent connections with the server_persistent_connections and client_persistent_connections directives.
3. Disable any advanced TCP features on the Squid system. Disable ECN on Linux with echo 0 > /proc/sys/net/ipv4/tcp_ecn/.
4. Upgrade to Squid-2.5.STABLE4 or later to work around a Host header related bug in Cisco PIX HTTP inspection. The Cisco PIX firewall wrongly assumes the Host header can be found in the first packet of the request.

If this error causes serious problems for you and the above does not help, Squid developers would be happy to help you uncover the problem. However, we will require high-quality debugging information from you, such as tcpdump output, server IP addresses, operating system versions, and access.log entries with full HTTP headers.

If you want to make Squid give the Zero Sized error on demand, you can use the short C program below. Simply compile and start the program on a system that doesn't already have a server running on port 80. Then try to connect to this fake server through Squid:

#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include <assert.h>

int
main(int a, char **b)
{
struct sockaddr_in S;
int s,t,x;
s = socket(PF_INET, SOCK_STREAM, 0);
assert(s > 0);
memset(&S, '\0', sizeof(S));
S.sin_family = AF_INET;
S.sin_port = htons(80);
x = bind(s, (struct sockaddr *) &S, sizeof(S));
assert(x == 0);
x = listen(s, 10);
assert(x == 0);
while (1) {
struct sockaddr_in F;
int fl = sizeof(F);
t = accept(s, (struct sockaddr *) &F, &fl);
fprintf(stderr, "accpeted FD %d from %s:%d\n",
t, inet_ntoa(F.sin_addr), (int)ntohs(F.sin_port));
close(t);
fprintf(stderr, "closed FD %d\n", t);
}
return 0;
}



As Daniel said though, it could be triggered because your server is over-loaded. Watch your memory usage, CPU usage and check Node distribution (if applicable) in your server Control Panel. But even then, Squid should not be failing - it should have a Code 500 instead - so this suggests that the Squid itself is having a freak attack because it's misconfigured or something else more complicated is wrong.

All in all, this is probably not a problem with JoomlaComment itself but a specific code function for Joomla/PHP that caused it. Try jReviews for the heck of it, apparently it can throw a Zero sized reply for Squid servers too.

Zero Reply? I think the squid is swimming too deep... LMAO 9 years 10 months ago #7813

  • JonusC
  • JonusC's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 785
  • Thank you received: 48
Also try disabling AJAX support in the JoomlaComment backend - just to see if that fixes the error. Otherwise, you will need to talk with your server company I think :(

Zero Reply? I think the squid is swimming too deep... LMAO 9 years 10 months ago #7818

  • chomz
  • chomz's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
thank you for your outstanding efforts to help me solve my problem, guys... :kiss: :kiss: :kiss:

it's ok, may be it's my server.. i use a paidhosting service and i will reconsider to change my host server (because of too many errors others than this one... now i am rebuilding my site back from zero ,i lost all my dbase and contents :S :S )
see you when i have enough money to buy better hosting service, guys :kiss:
keep the service good like this, this is the most helpful support forum i've ever joined with.. too pity i cannot enjoy your extensions for now :(

Zero Reply? I think the squid is swimming too deep... LMAO 9 years 10 months ago #7819

  • JonusC
  • JonusC's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 785
  • Thank you received: 48
Oh well that's a shame, sounds like the web host company might be a bit funny...

If I might give some personal, non-CompoJoom advice, I actually have my current site on HostGator.com. Their cheapest plan which is Shared Hosting, is only USD$5 per month, they work 100% with Joomla and I have never had a problem with them. They also give you many more features than others do for the same price, such as Jailed SSH access (Linux commandline) which is very surprising and very useful for advanced tasks!

I am not an affiliate or anything of them, but I am really impressed with their service and personally recommend them to everyone I know. Not to mention - because I use them myself, I can easily know if the host is good and provide better support haha!

Take a look at the Hatchling plan on this page here for details - www.hostgator.com/shared.shtml

You will see that they have many modern and advanced features like PHP5, Ruby on Rails, GD2, Image Magick (that one is GREAT for Joomla extensions, such as Community Builder)... and yeah. So if you don't mind having your site hosted in the USA, I would recommend they are worth a look - as I can personally say they are great and working 100% in every Joomla thing I have used (which is a lot) :)
  • Page:
  • 1
Time to create page: 0.090 seconds