×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: !JoomlaComment template not found: mydefault

!JoomlaComment template not found: mydefault 12 years 2 months ago #6273

  • lon jones
  • lon jones's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
I just moved my site from localhost to a remote server. It all works :o - except for joomlacomment. When I click on the menu to go to the "leave a comment" section of my site I get a white screen that says:

>>> !JoomlaComment template not found: mydefault <<<<

The template is indeed on the remote site.

Here are some clues that the experts might understand (I'm not an expert - yet)

Deep within the component !joomlacomment (on the remote server) under "content settings/layout" in the "template" section I found in red letters -

Your customized template:
Location:/www/domainname.com/web/domainname/domainname/media IS NOT writable

as compared to the same place on the localhost which says -

Your customized template:
Location:C:Program Filesxampphtdocsdomainnamemediamyjosctemplates IS writable

Right next to the red letter message on the remote host it says "HTML use standard" as compared to the local host which says "HTML mydefault" and then under that "CSS".

Everything else in the template section is set the same on both the local and remote servers.

I tried to make changes on the remote server but it wouldn't let me.

I guess this means I need to somehow either make the contents of directory "myjosctemplates" writeable, or rewrite them by hand using a text editor, or ???

Any advice?

Just for the record here are the rest of the settings in the templates section:

Standard template: html = modern css = css

Copy current standard template to customized template directory = no

Modify current customized template = no

Include javascript library = yes

Columns number of the input area = 40

Joomlacomment ver = !JoComment 4.0 alpha3 by Compojoom.com

remote server has php 5

!JoomlaComment template not found: mydefault 12 years 2 months ago #6274

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
make the media folder writable and make sure that the template is uploaded to it.

You can always switch to the standard template(not your modified one)

!JoomlaComment template not found: mydefault 12 years 2 months ago #6276

  • lon jones
  • lon jones's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Exactly.

The problem is I don't know how to make the media file writeable.

Any clues?

!JoomlaComment template not found: mydefault 12 years 2 months ago #6279

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
open your site with ftp program such as filezilla. right click on the folder - rights and set 775.

!JoomlaComment template not found: mydefault 12 years 2 months ago #6285

  • lon jones
  • lon jones's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
As usual - your suggestion worked.

thanx

lon
  • Page:
  • 1
Time to create page: 0.122 seconds