×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Installation issue

Installation issue 11 years 2 months ago #110

  • Ben
  • Ben's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
So I just installed joomlacomment on my 1.5.2 site. I have very high hopes for it!

I'm having a fairly major issue at this point that I'm hoping you can help me with. When I type in a comment, and put in the correct captcha code, then click send, I see the little spinning arrows for a second, but it just goes back to my comment entry, and the comment doesn't look like it's inserted in the database.

It looks like everything is installed properly; I see all the directories in the components directory, and the tables got created. So, I'm just not sure where we could be going wrong here.

Also, another minor issue is that the labels for all my fields are white on white, so I can't read them. Any idea there?

Any help would be appriciated. Thanks in advance!

Installation issue 11 years 2 months ago #112

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
What do you mean with "it just goes back to my comment entry"?
Do you mean the comment form, or your published comment? The page must not refresh to save the comment in the database (we are using ajax: en.wikipedia.org/wiki/Ajax_(programming) )

Installation issue 11 years 2 months ago #115

  • Ben
  • Ben's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
Sorry, that is a little vague. Let me clarify.

When I click save, the form is re-displayed with my entries still populating the fields. The page itself isn't refreshing, but the comment isn't being written to the db.

I hope this clears it up. If not, let me know what else may help.

Installation issue 11 years 2 months ago #120

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Can you give me the URL of your web site? I don't understand very well what is not working and why.
Thanks!

Installation issue 11 years 2 months ago #196

  • archiquotes
  • archiquotes's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
hi Daniel.

Thanks for the great extension. The installation was simple and quick. Everything seems fine except that I'm having the same problem as Ben. Comments are not successfully posted when I hit the "SEND" button. Have I missed out any thing during the installation? My website's link is as follow: ArchiQuotes.info]

Installation issue 11 years 2 months ago #197

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
The most common problem for that are changes to the language file. Did you do something like that?

Installation issue 11 years 2 months ago #198

  • archiquotes
  • archiquotes's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Hi Daniel.

Thanks for your reply.

I didn't do anything to the language file. Do I have to?

Installation issue 11 years 2 months ago #199

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Did you make changes to the template?

Installation issue 11 years 2 months ago #200

  • archiquotes
  • archiquotes's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Neither. Didn't do any changes.

Installation issue 11 years 2 months ago #202

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hm, strange. Can I get super admin access to your web site?

Installation issue 11 years 2 months ago #209

  • archiquotes
  • archiquotes's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
I've just PM you the super admin login details.

Thanks

Installation issue 11 years 2 months ago #213

  • archiquotes
  • archiquotes's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Hei, Daniel.

Thanks a lot. It works now. How did you do that? All I notice is that, the right module has been deactivated.

Installation issue 11 years 2 months ago #214

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
No, it is not working. I turned off the ajax support - then it is working. But it should do everything with ajax turned on. We are still looking for the problem.

Installation issue 11 years 2 months ago #217

  • archiquotes
  • archiquotes's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Yup, it's quite unstable.

Installation issue 11 years 2 months ago #218

  • archiquotes
  • archiquotes's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Having problem with posting again. Comment is not appearing.

Installation issue 11 years 2 months ago #231

  • archiquotes
  • archiquotes's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Daniel

I think I've found the solution to the problem. This is what I did:

# Open the htaccess.txt file.
# Edit the RewriteBase line to RewriteBase /joomla
# Save the file
# Then rename htaccess.txt to .htaccess

It worked! However, I'm not sure if these changes could pose any security problem to my site.

Thanks.

Installation issue 11 years 2 months ago #234

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Well, cheers :)

It is an interesting solution!
  • Page:
  • 1
Time to create page: 0.097 seconds