×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Banlist not working

Banlist not working 11 years 6 months ago #9174

  • Aaron Severson
  • Aaron Severson's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
I'm using !joomlaComment 4.0 RC1 on my site ( ateupwithmotor.com ). I've been struggling with comment spam. Each time I get a spam comment, I paste the IP address into the ban list, in hopes of discouraging that bot.

I hadn't really reviewed the IPs on the ban list until this morning. I discovered that each of the IP addresses I had listed there was listed multiple times -- which means I continued to get comments from that IP address after I had added it to the ban list.

I don't use Akismet, just the basic Joomlacomment system.

What can I do to block these IPs from commenting in the future?

Thanks!

Banlist not working 11 years 6 months ago #9175

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hm, this sounds really strange to me Aaron. Would you examine the block list again, are all IPs just separated with comma?

Banlist not working 11 years 6 months ago #9177

  • Aaron Severson
  • Aaron Severson's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Yes, all IPs are separated with commas. 1.11.111.11,2.22.222.22 and so on.

Banlist not working 11 years 6 months ago #9192

  • JonusC
  • JonusC's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 785
  • Thank you received: 48
You are correct, I can't ban myself on localhost (127.0.0.1) even. I will look at this right now, thanks for the report!

Banlist not working 11 years 6 months ago #9193

  • JonusC
  • JonusC's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 785
  • Thank you received: 48
No, I cannot replicate it (I was logged in as Administrator). I set the banlist to
10.12.32.182, 127.0.0.1
...with NO trailing comma. The space after the comma doesn't matter. The 10.12.x address is just made up, but when I try to comment on this I get 'Request Failed'.

Banlist not working 11 years 6 months ago #9194

  • Aaron Severson
  • Aaron Severson's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
I haven't tried to replicate it myself -- I just know that I've received spam comments from IP addresses that are on the banlist.

Banlist not working 11 years 6 months ago #9195

  • JonusC
  • JonusC's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 785
  • Thank you received: 48
This might be another one of those things like the UBBCode bug we had, just some code isn't being run or something. Could you make screenshots of all your JoomlaComment settings and send them to me? This way I can set the same on mine and narrow it down. You can Zip/Email to me via jc [AT] sonus-online.net

Also, I assume these spammers are anonymous/guests? Because if you set an IP ban for a member, it still goes through when they're logged in. This is by design.
  • Page:
  • 1
Time to create page: 0.195 seconds