×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: ...unexpected T_OBJECT_OPERATOR error? Read here!

...unexpected T_OBJECT_OPERATOR error? Read here! 8 years 3 months ago #6343

  • JonusC
  • JonusC's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 785
  • Thank you received: 48
Do you get an error like this after trying to use JoomlaComment4?
Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /somefile.php on line 11


Doesn't matter if it's not exact, the unexpected T_OBJECT_OPERATOR means you have PHP4 on your webhost. JoomlaComment 4 requires PHP version 5.x to function, please contact your webmaster/provider to update your server.

We can't fix this, it is possible to hack it to work on PHP4, but this is a security risk and also breaks other advanced functions. As such, anyone with this error or who is running PHP 4 will not get any support (Paid Support excluded).

If you are certain you have PHP5 and still receive the error, reply here. You can check your PHP version under Joomla! Administration (backend) > Help menu > System Info.

Thank you for the continued bug reports, suggestions, and most of all - for using JoomlaComment! :)
  • Page:
  • 1
Time to create page: 0.077 seconds