×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Akismet does not work

Akismet does not work 12 years 4 months ago #5206

  • Alex
  • Alex's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 39
  • Thank you received: 0
I've got Akismet key and enabled it.

If I post anything, get this error apparing instead of my post text, right in the message input area

<br />
<b>Parse error</b>: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in <b>/home/aivanov/public_html/gorbostroyka/components/com_comment/classes/akismet/Akismet.class.php</b> on line <b>66</b><br />

Akismet does not work 12 years 4 months ago #5208

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Do you have php5?

Akismet does not work 12 years 4 months ago #5210

  • Alex
  • Alex's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 39
  • Thank you received: 0
My cpanel says:
PHP version 5.2.6

In the same time, I had "unexpected T_OBJECT_OPE" problem which suggests issues with PHP version...

As described here:
compojoom.com/forum/6-bug-report/2413-pa...cted-tobjectope.html

BTW given how simple the T_OBJECT_OPE fix is, do you want to include it in the next version of joomlacomment?

Akismet does not work 12 years 4 months ago #5212

  • Alex
  • Alex's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 39
  • Thank you received: 0
Wow!!!

I'd run phpinfo and I've got PHP Version 4.4.9

Obviously some issues with my provider... can I upgrade safely to php5? Is it backward compatible? I have lots of other stuff on the same account...

Akismet does not work 12 years 4 months ago #5213

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Nice that you found out the problem :)

Well, I don't plan to include the fix since I've already mentioned in a blog post that the minimum system requirements for joomlacomment are php5 and mysql5. I will add this to the readme file too.

Akismet does not work 12 years 4 months ago #5431

  • JonusC
  • JonusC's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 785
  • Thank you received: 48
Alex wrote:

Wow!!!

I'd run phpinfo and I've got PHP Version 4.4.9

Obviously some issues with my provider... can I upgrade safely to php5? Is it backward compatible? I have lots of other stuff on the same account...


It is easily possible to migrate from PHP4 to 5, but you'll have to contact your webhost provider about that.

Also there may be problems with character conversion. If it's not possible to simply erase all your SQL databases after upgrading to 5, you'll need some advanced help for that.

I'm sure your webhost will provide the solution for you :)
  • Page:
  • 1
Time to create page: 0.168 seconds