×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Forwarding after submitting a new hotspot

Forwarding after submitting a new hotspot 1 year 9 months ago #33251

  • Tomasz Kolasa
  • Tomasz Kolasa's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 36
  • Thank you received: 0
Hello Daniel,
it's me again :D Hope Your not mad. I am not sure is this supposed to be a bug or feature request. Now if I have two (or more) maps in which I display filtered localizations - lets say that half of filters covers in both maps. If I open hotspot description in Map 1 (with template 1) then I'll be sent to description page in template 1. If I Open same hotspot description but in Map 2 (with template2) then I'll be sent to description page in template 2. And that's ok - works like charm, but after submitting hotspot I am always sent to Map 1 with template 1. I understand (probably) how this works, it just sends You to first Map with such a category filter. But it could work little diffrent like sending You to Map with choosen (at submission) category filter and least number of other filters then it would probably match better Map (and template). On my page I have something like this:
Map 1 - Generic map - displays almost all categories
Map 2 - displays one out of all categories
Map 3 - displays three out of all categories
etc. and because of Generic map it always sends You to that generic map which is diffrent page and layout.

I did my best to try explain it, hope You get me. :D
Sincerely,
Thomas

PS: Thank You for fixing other bugs (like the tour with menu closed and png images). :)

Forwarding after submitting a new hotspot 1 year 9 months ago #33256

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Mad? I hope not :) I'm actually quite happy that occasionally I get users like you that do crazy stuff with our components and that way help us better understand what you guys try to do and find the details that we've missed. At the end if you are able to accomplish your project with our components, then you would buy a new subscription next year, right? So, no, no! Not mad :)

Back to the issue. I'm aware of the issue and it always had low priority. The problem is that we are not finding the correct itemid. Why aren't we finding the correct itemid? Because it is a crazy stuff that involved a lot of hair pulling, banging a head against a wall and just thinking wtf. I'll give it a try again and will let you know if it works.

Regards,
Daniel

Forwarding after submitting a new hotspot 1 year 9 months ago #33257

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hm, wait! I think that I didn't understand the issue. I just tested it and it seems to work the way I thought it didn't.
I have 2 categories and 2 menus (Education and Restaurants). For the education menu I've selected the filter category to be education. For restaurants I've selected restaurants.

So, when I view the maps -> If I click on readmore of a hotspot that is from the education category I get redirected to teh education menu and if I click on restaurants I go to the restaurants menu. This works as it should.
Now the submission - it works the same way. If I select the education category during submit, then when I get redirected I'm sent to the education menu. If I select restaurants I'm redirected to the restaurants menu. So, what's the issue again here?

REgards,
Daniel

Forwarding after submitting a new hotspot 1 year 9 months ago #33258

  • Tomasz Kolasa
  • Tomasz Kolasa's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 36
  • Thank you received: 0
Now add a third map which shows all of them (like a map of city with all crucial spots) and for me after submitting new hotspot it goes to that third generic map (I created that map earlier then the single category maps - maybe this is the cuase of bug?). Check it out. :) Gone write more tommorrow. I am in a rush! :(

Forwarding after submitting a new hotspot 1 year 9 months ago #33262

  • Tomasz Kolasa
  • Tomasz Kolasa's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 36
  • Thank you received: 0
Hello again Daniel,

so I asked my server administrator for another hosting and he's ok with it. I will install there Joomla with Hotspots and show You the bug.
So about Your extension and site that I am working on. This is big official website for not so big city in Poland. :D But I see great potential in Hotspots that's why I chosen Your extension. :) And yes, You are right about next year subscription. If the website will be successful I'll make sure we extend subscription next year. Also when I'll have less work on my mind I'll bug You about some features that I would love to see. ;) Btw. I am happy that You're not mad, that just means that You care.

Sincerely,
Thomas
  • Page:
  • 1
Time to create page: 0.081 seconds