×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: PRO 5.2 google maps wrong url with language param

PRO 5.2 google maps wrong url with language param 6 years 8 months ago #32994

  • Brecht Coene
  • Brecht Coene's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 49
  • Thank you received: 0
After upgrade to 5.2 map doesn't show. In console is 404 for maps.googleapis.com/maps/api/js&language=nl
<script src=" maps.googleapis.com/maps/api/js&language=nl " type="text/javascript"></script>
Should be maps.googleapis.com/maps/api/js?language=nl

PRO 5.2 google maps wrong url with language param 6 years 8 months ago #32995

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Do you have a template override or something? I tested it with custom language for the map and it loads just fine for me. The code that generates the url is in the utils helper class and we have this:
		if (count($params))
		{
			$url .= '?' . implode('&amp;', $params);
		}

If we have any parameters we will first add the ? sign and then we will implode the params with & If you have just a single value in params, implode won't prepend anything to it.

Regards,
Daniel

PRO 5.2 google maps wrong url with language param 6 years 8 months ago #32998

  • Brecht Coene
  • Brecht Coene's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 49
  • Thank you received: 0
yes, it was our code in override of hotspots/default.php We used to add language param with & to getGmapsUrl() output.
Before version 5.2 it used to work.

Can be closed.

PRO 5.2 google maps wrong url with language param 6 years 8 months ago #32999

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Now you have a language parameter for this. It's under the map settings.
  • Page:
  • 1
Time to create page: 0.186 seconds