×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Answer to comments gets posted without moderation

Answer to comments gets posted without moderation 4 years 6 months ago #21029

  • Gerhard Sitzmann
  • Gerhard Sitzmann's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 41
  • Thank you received: 0
Hello,

in my custom template the answers to comments get posted immediately, without moderation.

In the default template they have to be allowed by moderator first.

I want my template to behave the same way.

But I can't seem to find which piece of code regulates that. I think I threw it out accidentally when working on my custom template.

Could you please tell me which piece of code is responsible for hiding answers to comments until they are published by moderator. Thank you.

Cheers
gerhard

EDIT:
In the backend the answers to comments are marked as unpublished. But they are visible on the frontend. Even if I'm not logged in.

Answer to comments gets posted without moderation 4 years 6 months ago #21033

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
So, what happens in the default template? Don't you get a message -> your comment needs to be approved before it is published? Or do you see a comment that has opacity?

Answer to comments gets posted without moderation 4 years 6 months ago #21035

  • Gerhard Sitzmann
  • Gerhard Sitzmann's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 41
  • Thank you received: 0
In the default template I don't get that message.

I see a comment that has opacity. On hover it looses opacity. When I'm logged in I see the button "Publsih". So Iguess it is unpublished.

In the backend the status of the comment is unpublished.

I'm still using the Core 5.0RC1 version, not Pro.

Answer to comments gets posted without moderation 4 years 6 months ago #21037

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
In one of the latest ccomment dev updates I added a message:
awesomescreenshot.com/0791ctf09a

Now the comments won't show anywhere, but the user will see the message.

Answer to comments gets posted without moderation 4 years 6 months ago #21040

  • Gerhard Sitzmann
  • Gerhard Sitzmann's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 41
  • Thank you received: 0
OK, I will try that dev update.

Could you please provide a link to it. Thank you.

EDIT: I found it here:
compojoom.com/component/ars/repository/dev-ccomment

Answer to comments gets posted without moderation 4 years 6 months ago #21042

  • Gerhard Sitzmann
  • Gerhard Sitzmann's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 41
  • Thank you received: 0
Hello Daniel,

I now installed latest dev update git0ff7eb6(Alpha).

In the default template answers to comments now have opacity until they are published.

I do not get the message that you mentioned in your last post.

In my custom template answers to comments get published immediately. Even when their status in the backend is unpublished.

Normal comments (not answers to comments) behave as they should.

Could you please point me to the piece of code that is responsible for hiding unpublished answers to comments.

Thank you.

EDIT:
Also when I want to answer to a comment and click "Send", nothing happens. I have to click again and then the comment gets posted twice.

PLEASE HOLD. I will do some thorough testing from different computers and IPs and then get back to you.

Answer to comments gets posted without moderation 4 years 6 months ago #21051

  • Gerhard Sitzmann
  • Gerhard Sitzmann's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 41
  • Thank you received: 0
Hello Daniel,

I'm done testing now. And these are the results:

-after submitting an anser to a comment, I do not get a message that the comment will undergo moderation
-immediately after submitting the comment, it is not visible
-after a refresh of the page it is visible, with opacity, to all visitors of the site
-the comment is marked as unpublished in backend and frontend

The behaviour is the same with the default template and my custom template.

I installed latest dev update git0ff7eb6(Alpha).

You can test it yourself at www.planevo.de/live/blog/5-blog-2.html

Please help. Thank you.

Answer to comments gets posted without moderation 4 years 6 months ago #21054

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Can I actually have access to your backend? I have the feeling that you've configured something not in a proper way -> unregistered users should not see any unpublished comments at all.

Regards,
Daniel

Answer to comments gets posted without moderation 4 years 6 months ago #21055

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hmmmm, you are partially correct. I get the message that the comments will not be published until moderated, but when I refresh the page -> replies to comments are shown :(

Will have a look at the code and let you know once it is fixed.

Daniel

Answer to comments gets posted without moderation 4 years 6 months ago #21056

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Okay - I just released a dev version that fixes that problem - nested unpublished comments won't be shown to normal users anymore. However I cannot reproduce the problem with the message as each time I post I get a "You comment will undergo moderation". Does your form have this:
		<div class="ccomment-error-form row-fluid hide">
			<div class="alert alert-error">
 
			</div>
		</div>

This is the div where we place the error/status messages.

Regards,
Daniel

Answer to comments gets posted without moderation 4 years 6 months ago #21057

  • Gerhard Sitzmann
  • Gerhard Sitzmann's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 41
  • Thank you received: 0
Hello Daniel,

thank you for checking.

I will install the latest dev release then to fix the vivibilty issue.

So the div for the messages is in my template. When I try to submit an empty comment, I receive an error message.

This is the complete code of my default_form.php
<?php if (!$this->discussionClosed) : ?>
	<?php if ($this->allowedToPost) : ?>
		<div class="ccomment-error-form row-fluid hide">
			<div class="alert alert-error">
 
			</div>
		</div>
	<div class="formcol1 clearfix">
	<?php if (!$user->get('id')) : ?>
		<div class=" ccomment-user-info hide">
				<input name='name'
				       class="ccomment-name span12 no-margin"
				       type='text'
				       value='{{user.getName}}'
				       placeholder="<?php echo JText::_('COM_COMMENT_ENTER_YOUR_NAME'); ?>"
				       tabindex="1"
					<?php if ($user->id) : ?> disabled="disabled" <?php endif; ?>
					/>
				<!--<span class="">
					<?php echo JText::_('COM_COMMENT_DISPLAYED_NEXT_TO_YOUR_COMMENTS'); ?>
				</span>-->
 
			<?php if ($this->config->get('template_params.notify_users')) : ?>
					<input name='email'
					       class="ccomment-email span12 no-margin"
					       type='text'
					       value=''{{user.getEmail}}''
						   placeholder="E-Mail Adresse*"
						   tabindex="2"
					<?php if ($user->id) : ?> disabled="disabled" <?php endif; ?>
					/>
					<!--<span class="">
						<?php echo JText::_('COM_COMMENT_NOT_DISPLAYED_PUBLICLY'); ?>
					</span>-->
			<?php endif; ?>
		</div>
	<?php if ($this->config->get('template_params.notify_users')) : ?>
		<label class="checkbox ccomment-notify">
			<input type="checkbox" value="1" {{#user.notify}}checked="checked"{{/user.notify}} name="notify"
			name="ccomment-notify" />
					<span class="">
						Ja, benachrichtigen Sie mich bei Kommentaren zu diesem Artikel.
					</span>
		</label>
	<?php endif; ?>
	<?php endif; ?>
	</div>
		<div class="formcol2 clearfix">
 
			<textarea name='comment' class='ccomment-textarea required' cols='5' tabindex="5"
			          rows='10'
			          placeholder="Schreiben Sie hier Ihren Kommentar:*"
			          style=""
				></textarea>
 
		</div>
	<div class="formcol3 clearfix">
	<?php if ($this->config->get('security.captcha') && ccommentHelperSecurity::groupHasAccess($user->getAuthorisedGroups(), $this->config->get('security.captcha_usertypes'))) : ?>
		<div class="ccomment-actions hide">
				<?php if ($this->config->get('security.captcha_type') == "recaptcha") : ?>
					<div class="ccomment-recaptcha-placeholder">
 
					</div>
				<?php else : ?>
					<div class="ccomment-captcha">
						<?php echo ccommentHelperCaptcha::insertCaptcha('security_refid', $this->config->get('security.captcha_type'), $this->config->get('security.recaptcha_public_key')); ?>
						<input type='text' name='security_try' id='security_try' maxlength='5'
						       tabindex='7' class='ccomment-captcha-input required'
						       placeholder="Sicherheitscode*"/>
					</div>
				<?php endif; ?>
		</div>
	<?php endif; ?>
		<div class="ccomment-actions hide">
			<?php if (!$this->config->get('security.auto_publish')) : ?>
				<div class="ccomment-undergo-moderation">
					<?php echo JText::_('COM_COMMENT_COMMENTS_UNDERGO_MODERATION'); ?>
				</div>
			<?php endif; ?>
				<button type='submit' class='semHeadLink ccomment-send'
				        data-message-enabled="<?php echo Jtext::_('COM_COMMENT_SENDFORM'); ?>"
				        data-message-disabled="<?php echo JText::_('COM_COMMENT_SAVING'); ?>" tabindex="7" name='bsend'>
					VERÖFFENTLICHEN >
				</button>
		</div>
	</div>
	<div class="clearfix"></div>
	<input type="hidden" name="contentid" value="{{info.contentid}}"/>
	<input type="hidden" name="component" value="{{info.component}}"/>
 
<?php else : ?>
	<div class="ccomment-not-authorised">
		<h5><?php echo JText::_('COM_COMMENT_NOT_AUTHORISED_TO_POST_COMMENTS') ?></h5>
 
		<p class="muted small">
			<?php if (!$this->config->get('security.auto_publish')) : ?>
				<?php echo JText::_('COM_COMMENT_COMMENTS_UNDERGO_MODERATION'); ?>
			<?php endif; ?>
		</p>
	</div>
<?php endif; ?>
<?php else : ?>
<div class="ccomment-comments-disabled alert alert-info">
	<?php echo JText::_('COM_COMMENT_DISABLEADDITIONALCOMMENTS') ?>
</div>
<?php endif; ?>

Answer to comments gets posted without moderation 4 years 6 months ago #21058

  • Gerhard Sitzmann
  • Gerhard Sitzmann's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 41
  • Thank you received: 0
I have installed the latest dev release and now ansers to comments are hidden until they are published by a moderator :)

For the message that is not shown, I will check my template again. If it persists I will open a new thread.

This one is solved now for me.

Thanks again.

Answer to comments gets posted without moderation 4 years 6 months ago #21060

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Also I just tested it on your site and I see the following message:

Your comment will appear on the site once a moderator has approved it.

Answer to comments gets posted without moderation 4 years 6 months ago #21061

  • Gerhard Sitzmann
  • Gerhard Sitzmann's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 41
  • Thank you received: 0
Do you see also see this message when you answer to an existing comment?

For new comments, I see it, too.

Answer to comments gets posted without moderation 4 years 6 months ago #21063

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Aaaaaah! the message is still there, but the form gets closed and that is why you don't see it.

Here on my installation I have the form on top and that is why (because of the way the code works) I always output the message in the first such div and I never saw that.

I'll fix this tomorrow and will let you know.

Regards,
Daniel
The following user(s) said Thank You: Gerhard Sitzmann

Answer to comments gets posted without moderation 4 years 6 months ago #21086

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
A new release is available. It should correct the problem.

Regards,
Daniel
  • Page:
  • 1
Time to create page: 0.163 seconds