×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Link in front page is not aligned

Link in front page is not aligned 11 years 1 month ago #13770

  • Enio Tsutsumi
  • Enio Tsutsumi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
Hello all,
I want to fix this problem and don't know how, as you can see in the image below the link in fontpage is not aligned, I have tried to disable the background image and no success, tried to make it bigger and no success too...
I have no idea how to fix this, someone please help!

Link in front page is not aligned 11 years 1 month ago #13771

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Give me a link to your page please :)
Daniel

Link in front page is not aligned 11 years 1 month ago #13773

  • Enio Tsutsumi
  • Enio Tsutsumi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
www.crazy-panda.com
in the front page.
Thanks for fast reply.

Link in front page is not aligned 11 years 1 month ago #13774

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Enio,
just to understand this right - you want to remove the background picture or you want to align the button right from the image, or both???
Cheers,
Daniel

Link in front page is not aligned 11 years 1 month ago #13783

  • Enio Tsutsumi
  • Enio Tsutsumi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
Hi,
Just to align the button, something like this (in the image).

Link in front page is not aligned 11 years 1 month ago #13788

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
What do you say about removing that background image?
.write_comment .readon {
background: none!important;
}

Add this line to your css template file and you the readon should not have any background.
Is this a solution that you like?
Daniel

Link in front page is not aligned 11 years 1 month ago #13792

  • Enio Tsutsumi
  • Enio Tsutsumi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
Actually is not what I wanted but it works.
I wanted to make "write comments" link aligned to the background.

Link in front page is not aligned 11 years 1 month ago #13799

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
If you want this button to be properly aligned please give me a link where I can see a normal readon button. Then I will be able to tell you what you need to change.

Cheers,
Daniel

Link in front page is not aligned 11 years 1 month ago #13802

  • Enio Tsutsumi
  • Enio Tsutsumi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
I was using that code you gave me, now I deleted, and you can see the background again...
The link is crazy-panda.com/

Link in front page is not aligned 11 years 1 month ago #13803

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Enio,
I can't tell you what to do, because I don't know how your original readon is created.

You see our button has a class readon. In your stylesheet this class has a background - the background that you see.

Now that is all ok, but this image has a rounded corner on the right and it should have one on the left as well. And I guess that we should put a span in the a tag, but I'm not sure. I need to see the original in action and then I can tell you what you need to change...

Right now I don't see the same button anywhere on your page.
Daniel

Link in front page is not aligned 11 years 1 month ago #13811

  • Enio Tsutsumi
  • Enio Tsutsumi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
Hi Daniel,
I found this code in Stylesheet, I dont know if it helps or not.

.readon {background: url(../images/body/style5/readon-r.png) 100% 0 no-repeat;}
.readon span, .readon .button {background: url(../images/body/style5/readon-l.png) 0 0 no-repeat;color: #fff;text-shadow: 1px 1px 2px #000;}
.bodylevel-low .readon {background: #393939;border: 1px solid #444;}
.bodylevel-low .readon:hover {background: #316A9F;border: 1px solid #3FAAFF;}
.bodylevel-high #rt-accessibility, .bodylevel-med #rt-accessibility {background: url(../images/body/dark/fontsizer.png) 50% 0 no-repeat;}

Thanks

Link in front page is not aligned 11 years 1 month ago #13818

  • Enio Tsutsumi
  • Enio Tsutsumi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
Here is a link for readon button in action.
crazy-panda.com/index.php?limitstart=5&lang=ja
I had to disable comments because together it doesn't work, and layout become all mess up.

Thanks

Link in front page is not aligned 11 years 1 month ago #13819

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Enio,
So here is what you need to do. Log into your backend. Go to components->compojoomcomment->settings -> com_content --> layout tab.

There first copy your template, then select the option to modify it. You will see 2 new tabs - html and css. Go to the html tab and you will see this code:
{readon}
	<div class='write_comment readmore'>
		<a href="{READON_LINK}#JOSC_TOP" class="readon">{READON_WRITE_COMMENT} ({READON_COUNT} {READON_COMMENTS})</a>
	</div>
	{BLOCK-preview}
	<div class='comment_preview_container' style='clear:both'>
		{preview-lines}
	</div>
	{/BLOCK-preview}
{/readon}
change it to
{readon}
	<div class='write_comment readmore'>
		<a href="{READON_LINK}#JOSC_TOP" class="readon"><span>{READON_WRITE_COMMENT} ({READON_COUNT} {READON_COMMENTS})</span></a>
	</div>
	{BLOCK-preview}
	<div class='comment_preview_container' style='clear:both'>
		{preview-lines}
	</div>
	{/BLOCK-preview}
{/readon}
Don't forget to save :)

Is this solving the problem?
Daniel

Link in front page is not aligned 11 years 1 month ago #13823

  • Enio Tsutsumi
  • Enio Tsutsumi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
Hi Daniel,
Working PERFECT!!!
Thank you so much, you are the best!

Re: Link in front page is not aligned 10 years 6 months ago #15437

  • Jim Ewart
  • Jim Ewart's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Daniel, I am not sure if this related, however... I have three blog entries on the page. On the first one, I get the link "Write comment (0 comments), however on the 2nd and 3rd, it displays "ite comment (0 comments). I tried adding the <span> as you suggested but it didn't help. Thank you. If you want to see it in action, the url is dalrockperfdev.com/staging/index.php/business-tips

BTW, this is a very nice plugin, i found it very easy to setup.

Re: Link in front page is not aligned 10 years 6 months ago #15438

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Jim,
This is a specific css problem with your template.
The second, third article have different css classes. (you can look for the difference with firebug)
A fast solution would be to add the following css to your template:
.item .write_comment {
padding-left: 15px;
} 

Cheers,
Daniel

Re: Link in front page is not aligned 10 years 6 months ago #15475

  • Jim Ewart
  • Jim Ewart's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Daniel,

Thank you for the quick response. While looking at your suggestion, I realized that the truncated Write text was on the 1st page of the blog, right below Read More. I went into the settings and discovered that the problem goes away if:
* Set 'Show "Read On"' to No
* Set 'Do not show if detail link exists'

I will file your suggestion for future reference in case it re-occurs.

Jim

Re: Link in front page is not aligned 10 years 6 months ago #15476

  • Jim Ewart
  • Jim Ewart's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Daniel,

Further update. I decided to test your suggestion by adding the css to the layout css file. Problem solved, so now it can go either way.

Thanks again.
  • Page:
  • 1
Time to create page: 0.192 seconds