×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Upgrade 5.02 to 5.2.2

Upgrade 5.02 to 5.2.2 2 years 10 months ago #29343

  • Olivier NOBILI
  • Olivier NOBILI's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Hello, I have the 5.0.2 pro version on my joomla 2.5.27. But I can't update my version to the 5.2.2
If I click on the update link, it doesn't work. Something like, no xml installation file in the archive is shown.
If I downlad the 5.2.2 core version zip, and install via the extension manager, it works, but the comments are not shown anymore in the articles. Sounds like a db schemen difference between 5.0.2 and 5.2.2

So my question is : how to update , keeping my old comments
Thank's in advanc e for your reply

Upgrade 5.02 to 5.2.2 2 years 10 months ago #29344

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hey Olivier,
Since you have a subscription don't take the core version but the PRO one.
In the backend are you sure that you've provided the correct download id.

The update should automatically apply the database changes. Make sure that after the update you go to the dashboard. (there we try to fix any db errors that might have happened after the update).
If it still doesn't work I would like to have a link to your site.

Cheers,
Daniel
The following user(s) said Thank You: Olivier NOBILI

Upgrade 5.02 to 5.2.2 2 years 10 months ago #29397

  • Olivier NOBILI
  • Olivier NOBILI's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Hello Daniel,
Thanks for your reply. I renewed my licence, so I have updated for the 5.2.2 Pro
But ccomment still donsn't work :(
The difference beetween the version is the url shape.
I Have on my local site (5.2.2) this kind of request for the JSon data for your component, but my server returns a 404
www.lexpemag.com/en-france/les-landes-a-...omponent=com_content
On the prod site (5.0.2)
The query on the same page is
www.expemag.com/index.php?option=com_com...omponent=com_content
And it works
If Locally (5.2.2) I try (without the sef url)
www.lexpemag.com/index.php?option=com_co...omponent=com_content
It Works

Probably a problem with the SEF and the way you build your query now. I disabled the SEF for the CComponent extension...
I Use MijoSef, last version
Thanks for your help, I hove you will be able to find a solution for me

Upgrade 5.02 to 5.2.2 2 years 10 months ago #29398

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
There was a setting in mijoSef. I forgot what it was - they are intercepting the ajax request and they should not do it. I had a customer with nearly the same problem (he was using hotspots) and he found the setting. I'll try to find out the ticket and will let you know.

Regards,
Daniel

Upgrade 5.02 to 5.2.2 2 years 10 months ago #29400

  • Olivier NOBILI
  • Olivier NOBILI's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
I don't find the option in Mijosef
I imagine you changed something, because with the same MijoSef it works with the 5.0.2 and not with the 5.2.2 :)
I Hope we'll find a solution

Upgrade 5.02 to 5.2.2 2 years 10 months ago #29405

  • Olivier NOBILI
  • Olivier NOBILI's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Some infomation that could help you
It seems to be in the baseUrl variable affection in the ccomment config

On my 5.0.2 site

compojoom.ccomment = {
user: {"loggedin":false,"avatar":"","token":"bcdbdfcea3ae51ba359033f43c60f4fa"},
item: {"contentid":1650,"component":"com_content","count":2},
config: {"comments_per_page":0,"sort":0,"tree":2,"form_position":0,"voting":1,"copyright":0,"pagination_position":0,"avatars":0,"gravatar":0,"baseUrl":"http:\/\/www.expemag.com\/","captcha_pub_key":"6Ld8ZegSAAAAAGw4956cmGTXRsT2_KKKo0Bck7HD"}
};

In the 5.2.2 site

window.compojoom=compojoom=window.compojoom||{};compojoom.ccomment={user:{"loggedin":false,"avatar":""},item:{"contentid":1650,"component":"com_content","count":2},config:{"comments_per_page":0,"sort":0,"tree":2,"tree_depth":5,"form_position":0,"voting":1,"copyright":0,"pagination_position":0,"avatars":0,"gravatar":0,"baseUrl":"http:\/\/www.lexpemag.com\/en-france\/les-landes-a-velo-pliant-et-packraft.html","captcha_pub_key":"6Ld8ZegSAAAAAGw4956cmGTXRsT2_KKKo0Bck7HD"}};


The php code which generate it, is in com_comment/helpers/utils.php where there is getJSConfig method

In 5.0.2 the code is

'baseUrl' => Juri::root()


in 5.2.2 the code is

$uri = JUri::getInstance();
$jsconfig = array(
[...]
'baseUrl' => $uri->toString(array('scheme', 'user', 'pass', 'host', 'port', 'path'))

Upgrade 5.02 to 5.2.2 2 years 10 months ago #29407

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Here is what the user wrote in teh ticket.

For mijoSEF, I disabled the following option and it worked
Configration --> Advance settings --> Set variable from overwritting the paired one

Disable this and let me know if it works.

Daniel

Upgrade 5.02 to 5.2.2 2 years 10 months ago #29412

  • Olivier NOBILI
  • Olivier NOBILI's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Hi,
I don't find this option, there is no more Advanced Settings in my version of mijoSEF
I tried some options in MijoSef but without success...
I changed the code in 5.2.2 and it works for me...
I changed
'baseUrl' => uri.toString(...) by Juri::root()

Upgrade 5.02 to 5.2.2 2 years 10 months ago #29425

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Here is what Denis from Mijo told me.

he/she must set the Router for ccomment as Disabled miwisoft.com/support/docs/mijosef/user-manual/extensions
[17.12.2014 21:40:42] Denis Dulici: pass him to us if still not able to do it


Regards,
Daniel

Upgrade 5.02 to 5.2.2 2 years 9 months ago #29505

  • Olivier NOBILI
  • Olivier NOBILI's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 0
Hi Daniel, thank you, but it's the first thing I did... and it wasn't the solution... But, no problem right now, I have my solution...
  • Page:
  • 1
Time to create page: 0.100 seconds