×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: commet area reduced

commet area reduced 6 years 9 months ago #22584

  • Bruno Saetta
  • Bruno Saetta's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Hello,

after the upgrade to last version of CComment, I see that the space reserved for comments is too tight, as in the image (1

). The same problem with Firefox, Opera, IE and Chrome.

Here a link:
brunosaetta.it/diritto-autore/in-gran-br...ritti-dell-uomo.html

Firebug says (image 2

): textarea.ccomment-textarea.span12.required
I don't know what that mean :(
Attachments:

commet area reduced 6 years 9 months ago #22586

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Go to the settings under template enable the bootstrap emulation. Let me know if it is OK after that.

commet area reduced 6 years 9 months ago #22588

  • Bruno Saetta
  • Bruno Saetta's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Thanks for fast reply. Now it's ok.

Anyway I see that the articles with too many comments don't show the area for a new comment. There is a limit for the comments, or could be a server problem? Thanks in advance.

Example:
brunosaetta.it/diritto/internet-e-pornografia.html

commet area reduced 6 years 9 months ago #22589

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
No, Bruno - there is something else going on.
The view that you have in this article is reserved for search engines. Normally comments are loaded with an ajax request in the background -> in your case this is what search engines see when they visit the page. Can I have a look at your background?

Daniel

commet area reduced 6 years 9 months ago #22590

  • Bruno Saetta
  • Bruno Saetta's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Oh yes, thanks.
xxx

commet area reduced 6 years 9 months ago #22600

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Bruno,
The issue is with sh404. If you turn it off and go to the article you'll see that the comment system works.

For some reason sh404 is setting the "_escaped_fragment_" variable in the url and we are picking this up. Can you send me ftp access? I want to debug on your server. (either create a private ticket or send a mail to This email address is being protected from spambots. You need JavaScript enabled to view it.)

Regards,
Daniel

commet area reduced 6 years 9 months ago #22604

  • Bruno Saetta
  • Bruno Saetta's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Thanks Daniel,

you have mail.

commet area reduced 6 years 9 months ago #22612

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Bruno,
It actually turned out that the problem is not sh404, but the joomla cache (I guess that when you turn off sh404, it clears the cache).

CComment is not going to work with Joomla's cache turned on.

The problem is - Joomla is trying to cache the output of the whole page. Which is theoretically fine, but it is fine only for static content & not dynamic one. Comments are dynamic -> I need to know the user that is currently browsing the page etc.

In your case the issue is that joomla is creating the same cache for the menu item, no matter what the url parameters look like. For example, when you add &_escaped_fragment_ to the url we render the comments for the search engines as per specification developers.google.com/webmasters/ajax-cr...docs/getting-started

Now the thing is -> when you go the url without the &_escaped_fragment_ then joomla will serve the cache that it generated for the page with _escaped_fragment & those 2 are not the same.

CComment is optimized to work without joomla's cache (and we are constantly committed to improving the speed of the code).

Regards,
Daniel
The following user(s) said Thank You: Bruno Saetta

commet area reduced 6 years 9 months ago #22614

  • Bruno Saetta
  • Bruno Saetta's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 0
Ok Daniel,

thanks very much. So, i'll keep the cache off.
  • Page:
  • 1
Time to create page: 0.153 seconds