×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Add Configuration, Manage "Docman" Comments

Add Configuration, Manage "Docman" Comments 7 years 1 month ago #20670

  • Adrian von Allmen
  • Adrian von Allmen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Hi there,

First: Well done with the RC1!

I'm afraid I'll have some problems:
  1. Fatal error: Cannot instantiate abstract class ccommentComponentSettings in /home/httpd/vhosts/cuirina.de/httpdocs/components/com_comment/helpers/utils.php on line 56
  2. CComment plugin file for com_docmandoesn't exist

First Error is when I try to add a new config (my both old config disappeared and a "non existing" config is shown)

Second Error is, when I try to manage the comments. In the Dashboards the Comments are visible.

Any suggestion for the next steps?

Best Regards and keep up the great work!

Add Configuration, Manage "Docman" Comments 7 years 1 month ago #20672

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Adrian, which docman version are you using, can you send it to me to This email address is being protected from spambots. You need JavaScript enabled to view it.?

And I didn't understand the second error?

Add Configuration, Manage "Docman" Comments 7 years 1 month ago #20674

  • Adrian von Allmen
  • Adrian von Allmen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Hi Daniel,

You've got a Mail with some screenshots.

Thanks

Add Configuration, Manage "Docman" Comments 7 years 1 month ago #20678

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Adrian,
So the problem is that there is no plugin for docman in the version that you run.
Here is a new release that contains the docman plugin for 1.6.4
compojoom.com/component/ars/repository/dev-ccomment-pro

Please have a look at the docs once you install the new version:
compojoom.com/support/documentation/ccomment/ch03s02s21

You'll need to modify the template files again (the way we include the component changed and what you have there is for 4.2.1 and it doesn't work anymore).

Also in your backend -> delete the setting that you have there & and createa new setting for docman.

After that it should be all fine - comments should be displayed under the documents :)

Cheers,
Daniel

Add Configuration, Manage "Docman" Comments 7 years 1 month ago #20682

  • Adrian von Allmen
  • Adrian von Allmen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Thanks for your fast response.
I will have a look at the doc in this evening.

I already installed the build and now the Error-Message disappear and I can comments again. Great!

Still have trouble for saving (or delete) a config (as stated in the E-Mail with the Pictures of an empty-config).
Any Idea on this?

Cheers
Adrian

Add Configuration, Manage "Docman" Comments 7 years 1 month ago #20683

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Can you delete this config and create a new docman config?

Add Configuration, Manage "Docman" Comments 7 years 1 month ago #20688

  • Adrian von Allmen
  • Adrian von Allmen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
In the config window I have only a Checkbox with an empty line.

If I try to delete this "empty" config, I receive no message and it's still there.
If I try to add a new config I receive the "New config Saved" Message, but apparently it's not added.

Maybe a behavior of Akeeba Admin Tools?

Sorry for always being a difficult customer :)

Add Configuration, Manage "Docman" Comments 7 years 1 month ago #20689

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Naaa, Admin Tools is always accused for all world problems but I doubt that it has anything to do with that.

Let us do the following test -> can you create a config for let us say com_content? does it function properly? Can you delete it after that?

If it is working, then use phpmyadmin, navigate to #__comment_settings table and manually delete the row in there (the one that is supposed to be for docman).

Once you delete -> create a new config for docman. It should work properly.

If you are not able to create any config whatsoever, then please give me access to your site (backend + phpmyadmin) and I'll have a look at what is wrong there myself.

Thanks,
Daniel
  • Page:
  • 1
Time to create page: 0.147 seconds