×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Jomsocial Plugin Problem

Jomsocial Plugin Problem 11 years 2 months ago #11706

  • Matt Bryan
  • Matt Bryan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 0
Hello,
When I enable the Jomsocial Plugin for CompojoomComment and set it only to update the Activity Stream I get an error. I post a comment and first I get a Java popup telling me that the Request Failed. Then it populates the comment box with this:


Fatal error: Class 'CFactory' not found in /home/mysite/public_html/plugins/compojoomcomment/jomSocial.php on line 171

Fatal error: Class 'JLoader' not found in /home/mysite/public_html/libraries/loader.php on line 161

The comment is actually posted, but the whole process stalls out with this message in the box as if I never posted a comment. Also, the comment is not posted on the Activity Stream either.
I am using Jomsocial 2.0.4 and Joomla 1.5.22 and the latest version of this plugin.

Thanks for any help!

Jomsocial Plugin Problem 11 years 2 months ago #11709

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hm, are you using the latest version of the plugin? I remember the problem and I know that I fixed it.

Please confirm that you are using version 1.0.5. If you do, then please provide me with super admin access + ftp access and I'll fix the problem on your server. If you don't use the latest version, then please update to it.

Daniel

Jomsocial Plugin Problem 11 years 2 months ago #11710

  • Matt Bryan
  • Matt Bryan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 0
Hello,

Yes I am using the latest version, just downloaded it today and checked as well. I am testing out this setup on a localhost MAMP setup so I can't really give access. I do plan on installing on my live server once I get another issue fixed with MyBlog and CompojoomComment and then I'll send you the access so you could enable the plugin and see for yourself.

Thanks!

Jomsocial Plugin Problem 11 years 2 months ago #11725

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Thanks! Just PM me once you are ready!
Daniel

Jomsocial Plugin Problem 11 years 2 months ago #11727

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Ok fixed!
As you can see here:
www.jomsocial.com/support/docs/item/780-...activity-stream.html

The jomsocial documentation doesn't mention anywhere that one have to do this:
require_once( JPATH_ROOT . DS . 'components' . DS . 'com_community' . DS . 'libraries' . DS . 'core.php');
in order for the CFactory class to be included.

Now it is working as expected.
Daniel

P.S. Don't forget to make a review here: extensions.joomla.org/extensions/contact...ck/articles-comments :)

Jomsocial Plugin Problem 11 years 2 months ago #11728

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
ah, yes, there is also a new version of the pluign:
compojoom.com/downloads/downloads/compoj...comment-v106zip/view

Jomsocial Plugin Problem 11 years 2 months ago #11734

  • Matt Bryan
  • Matt Bryan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 0
Seems to work great now.
I did also leave you a nice review at the JED because your product deserves it.
Thanks for the help!
  • Page:
  • 1
Time to create page: 0.133 seconds