×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Language error help

Language error help 7 years 9 months ago #8286

  • Joyce
  • Joyce's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
We were able to resolve this- you were right- it was in the database- while parts were set correctly, we found that some were not. Now that it is all in the utf8 the comments are working. I also uninstalled it and reinstalled it. Between the two- it is now working. Yea!

Language error help 7 years 9 months ago #8289

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Online
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
nice :)
In 99% of the cases wrong database collation is the problem of everything!

Language error help 7 years 9 months ago #8293

  • Joyce
  • Joyce's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
as a newbie to the php database- I had to go carefully- but learned something new.
Thanks

Language error help 7 years 9 months ago #8354

  • Information Madness
  • Information Madness's Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 26
  • Thank you received: 0
Daniel,
I am also seeing the same issue. My visitors were posting comment in "Hindi" language and all I see is "??????". After reading this thread, I checked the jos_comment table and it was latin_swedish..." something.. So I changed the collation of the table to "utf8_general_ci" but I still see the same "?????" in the comments..

here is the URL..

informationmadness.com/cms/index.php?opt...ent_id=5629#josc5629

All my tables need to be "utf8_general_ci" ??

Thank you.

Language error help 7 years 9 months ago #8356

  • Joyce
  • Joyce's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
I think at least all t he jos_comment tables need to be changed to this "utf8_general_ci". Make sure that all the admin settings in joomla component for jos_comment are also set for your language. These steps worked for the Arabic. Other's here know more than I do- but these are my thoughts.

Language error help 7 years 9 months ago #8357

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Online
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
All tables and fields in the tables need to be utf8_general_ci

Language error help 7 years 9 months ago #8358

  • Information Madness
  • Information Madness's Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 26
  • Thank you received: 0
Ok I checked the table fields and they were set to "latin1_swedish_ci"..even though the table collation is "utf8-general-ci"..

I have installed JoomaMyAdmin.. how to change all the table and fields to "utf8_general_ci" ??

Thank you.

Language error help 7 years 9 months ago #8359

  • Information Madness
  • Information Madness's Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 26
  • Thank you received: 0
Got it working. I changed the jos_comments table to utf8_general_ci but the fields were still "latin1_swedish.." so I change the fields to "utf8_general_ci" and now its working fine.

Thank you guys.

Language error help 7 years 8 months ago #8858

  • eu
  • eu's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
Hello.
I have a problem with the romanian special character like ăîşţ . when I post a comment it shows ? character instead of the romanian special characters.
Also I have seen that in DEMO website you have the same problem.
Can you please tell me how to solve it ?

Regards.

Language error help 7 years 8 months ago #8859

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Online
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
hm the demo site has the same problem? I'll check it. Read what the other guys wrote and you will solve the problem.

Language error help 7 years 8 months ago #8860

  • eu
  • eu's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
Thank's Daniel. The problem with the Demo on the site is probably with the charset wich is not set on UTF-8 and it's in latin .
I solved my issue. The problem was that I did not made the modification on the proper table . So , as you said , the problem was from CHARSET witch was "latin"...
regards.

P.S. congrats on the comment extend...
  • Page:
  • 1
  • 2
Time to create page: 0.187 seconds