×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Language error help

Language error help 7 years 11 months ago #8182

  • Giorgi
  • Giorgi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
I have downloaded and installed joomlacomment,and tried to translate it to georgian, but when i uploaded language file on server,in place of words it shows ??????? ? ??? on site, i tried to change collation in phpmyadmin to utf8, but still nothing. the file i had translated i saved in utf8 too. sorry for my english, i hope you can help me.

Language error help 7 years 11 months ago #8188

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Are the comments shown with ???? or the strings in the language file?

Language error help 7 years 11 months ago #8189

  • Giorgi
  • Giorgi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
no comments are shown in georgian, and translated words in language file are georgian, but on site these words: "wright comment" "name" and other fields are shown with ?????

Language error help 7 years 11 months ago #8190

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
did you save the file in utf8 without BOM?

Language error help 7 years 11 months ago #8191

  • Giorgi
  • Giorgi's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
yes

Language error help 7 years 11 months ago #8192

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Zip the language file and post it here. I'm sure there is something wrong with it.

Language error help 7 years 11 months ago #8227

  • Joyce
  • Joyce's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
our website is unlimitedworld.org

I am getting ????? on comments written in Arabic. The charsets are utf8-general-ci and before that they were utf-8

It is set to Arabic on the front end-
Please advise.

I don't know how to do coding-

How can we make this work on an arabic language website?

Language error help 7 years 11 months ago #8228

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
go to your database with phpmyadmin and look for the collation of the tables. It should be utf8_general_ci.

Language error help 7 years 11 months ago #8230

  • Joyce
  • Joyce's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
from my server- database- in phpmyadmin the charset table is set to utf8_general_ci

in admin joomla- the joomlacomment charset has been set -I've tried both vtf-8 and vtf8_general_ci.

both ways it seems to produce the ???????
other thoughts? Am I understanding this correctly?

Language error help 7 years 11 months ago #8233

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Is the charset in the post or the language strings such as "send" shown with ????

Language error help 7 years 11 months ago #8234

  • Joyce
  • Joyce's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
can you give me more information. This is an example of what we see- both in the back end and front
See link below- and look at the comments.

www.unlimitedworld.org/index.php?option=...34:articles#JOSC_TOP

Language error help 7 years 11 months ago #8235

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Could you look in the database and tell us if the comments are properly stored? Are they readable when you look at them with phpmyadmin?

Language error help 7 years 11 months ago #8237

  • Joyce
  • Joyce's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
I see the comments in the administration- they are all ?????. If I go into the database itself- I assume you mean on the server... I am not sure how to find them. Can you guide me there?

Language error help 7 years 11 months ago #8238

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Open the database with phpmyadmin and go to the jos_comment table. This is where the comments are stored.

Language error help 7 years 11 months ago #8256

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
I know I am probably way off mark here, but, it looks to me almost as if the actual commenting system itself is correct, but that the problem resides with the editor not understanding things.
Just a thought...

Language error help 7 years 11 months ago #8257

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Nils what editor?

Language error help 7 years 11 months ago #8268

  • Joyce
  • Joyce's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
I had the same question- here is the system info- I think the settings are correct.

Language error help 7 years 11 months ago #8269

  • Joyce
  • Joyce's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
I had the same question-
My settings seem to be correct- so where do I find settings in the editor for the joomlacomment-

all the joomlacomments setting seem to be correct also?

Language error help 7 years 11 months ago #8279

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
Can't see the link to the posted comments now, but on the page that you come to, the editor field I was thinking of as the culprit, looked like this:

Cause, it seemed at least to me that everything else looked like it was appearing correct, but that the ????? ??? input was from this editor field and not anything else.
As if the editor field itself was not understanding what was being typed in.
And since everything else seemed ok, then it seemed that the problem is not with the language file, but in the editor.
You know, as if the editor itself is fourcing the input to end up as ANSI or something other than what it should be.

I know the Joomla editor JFK (I think) make a few versions of their editor to cater for international languages.

I assume this internal commenting editor field is somehow baked into the component. Could it be a simple fix, of the base file to be saved as UTF-8?

Once again, I am not a programmer, so sorry if this is just way of mark!

Language error help 7 years 11 months ago #8281

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
the so called "editor" is just an <textarea> field. This text area field sends the text to the database. And the problem is how the database stores the text.
It should store it in UTF8 and nothing else. If the database is not utf8, then we get ????? as output.
  • Page:
  • 1
  • 2
Time to create page: 0.106 seconds