×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: SINGLE HOTSPOTS funktioniert, MAP VIEW nicht?

SINGLE HOTSPOTS funktioniert, MAP VIEW nicht? 9 years 8 months ago #18132

  • Robin B.
  • Robin B.'s Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Hallo Zusammen,

schönes Produkt. Allerdings verstehe ich nicht,
warum nur das Anzeigen von einzelnen Hotspots
funktioniert (single hotsports),
es in der "Map View" aber nicht funktioniert.

Problem:
Auf der Map werden keine Hotspots angezeigt
und das Zoomen funktioniert nicht.

Was kann ich tun?

Grüße,

Robin

SINGLE HOTSPOTS funktioniert, MAP VIEW nicht? 9 years 8 months ago #18133

  • Robin B.
  • Robin B.'s Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Habe folgenden Artikel gefunden, der aber leider
noch nicht beantwortet wurde. Das Problem
beschränkt sich also auf Chrome. Wobei die
CompoJoom - Demo im Chrome funktioniert ...?!




28 Jul 2012 07:21
Torsten Roecker

HotSpots V3 - EDIT function and map problem
Dear all,

I've made a test installation of the new HotSpots V3 on my site there I found the following problems:

- Mapview and google chrome: Map is loading the Hotspots but not showing on the map. After selecting a single Hotspot by the side menue it shows the details and Zooms to the position but still no Icons. Single Hotspot function is working with chrome. (InternetExplorer 8 working without problems)

- EDIT function, after selecting the hotspot: Warning: implode() [function.implode]: Invalid arguments...
Category: Bug report

SINGLE HOTSPOTS funktioniert, MAP VIEW nicht? 9 years 8 months ago #18136

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hallo Robin,
Hast du im Backend bei der Kategorie-erstellung ein Schatten ausgewählt? Ohne Schatten gibt es im Chrome Probleme.

Gruß,
Daniel

SINGLE HOTSPOTS funktioniert, MAP VIEW nicht? 9 years 8 months ago #18146

  • Robin B.
  • Robin B.'s Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
O.k. das wars. Aufgrund der Schreibrechte in Joomla konnte
der Schatten nicht kopiert werden. Mit dem FTP Layer ging
es dann. Danke!

ANMERKUNG:
nach dem LiveUpdate von gestern, wurden mir in der
Konfiguration alles doppelt angezeigt. Vielleicht war's nur
bei mir so ...

WEITERE FRAGE:
Wenn ich in den FullScreen Modus gehe, bleibt
der Kopfbereich des Seitentemplates stehen.
Habe es mit dem z-Index versucht zu lösen, bin aber nicht
weiter gekommen. Idee?

SINGLE HOTSPOTS funktioniert, MAP VIEW nicht? 9 years 8 months ago #18150

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Das mit den doppelten Einstellungen in der Config ist nicht gut! Es ist irgendetwas falsch während des updates passiert :(

Fullscreen problem musst du genauso lösen - mit z-index.

Gruß,
Daniel

SINGLE HOTSPOTS funktioniert, MAP VIEW nicht? 9 years 8 months ago #18160

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
ok, sollte jetzt gefixt sein:
compojoom.com/downloads/hotspots/hotspots-3-2-1
Du kannst ruhig updaten - das wird auch die doppelte settings korrigieren.
Gruß,
Daniel

SINGLE HOTSPOTS funktioniert, MAP VIEW nicht? 9 years 7 months ago #18312

  • Robin B.
  • Robin B.'s Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Vielen Dank,

habe ich aktualisiert und die Komponente nun live im Einsatz.
Hier noch ein paar Fragen:

1) Wenn ich SEO URLs und ModRewrite anhabe wird die URL so:
/2012-10-18-08-20-18/einzelhandel.html#!/catid=4;19;8;32;17;13;42;1;6;15;28;35
Die Hotspot Kategorie meldet sich also so: 2012-10-18-08-20-18
Eine Unterkategorie: 2012-10-18-08-20-18/einzelhandel/buchhandlung.html#!/catid=8
lässt sich das verschönern?

2) bei zwei Kategorien versuche ich vergeblich den Standardschatten einzustellen.
Das Script hängt aber werder .png an die Datei, noch den Link der kopiert werden?
media/com_hotspots/images/categories/1352109315_S_
das ist bei 3 von 40 Kategorien so.

3) wäre es möglich, in der Auflistung im "Seitlichen Kartenmenü" die Einträge alphabetisch
sortiert zu bekommen?

4) wenn man mehrere Kategorien gleichzeitig ausgewählt hat (über einen Joomla Menüpunkt),
wäre eine TAB schön, der alle Inhalte zusammen alphabetisch auflistet. Springe ich in einen
speziellen TAB, werden erst dann nur die darin vorhandenen Hotsport angezeigt.


Viele Grüße,

Robin

SINGLE HOTSPOTS funktioniert, MAP VIEW nicht? 9 years 7 months ago #18323

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hallo Robin,
1. Das Datum in der URl zeigt nur das du ein menu Platzhalter (oder eigentlich "Menu item alias") - das hat nichts mit Hotspots zu tun. Hier musst du deine Menu struktur ändern. Das hier lesen: forum.joomla.org/viewtopic.php?t=628224

2. Versuchst du hier den Standardschatten auszuwählen oder einen Schatten hochzuladen?

3. Momentan ist das nicht möglich aber ich arbeite an eine Lösung

4. Das ist zu kompliziert um richtig gemacht zu werden. Deswegen würde ich es zur Zeit nicht auf der Todo liste setzten.

Gruß,
Daniel

SINGLE HOTSPOTS funktioniert, MAP VIEW nicht? 9 years 7 months ago #18330

  • Robin B.
  • Robin B.'s Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
1. Das Datum in der URl zeigt nur das du ein menu Platzhalter (oder eigentlich "Menu item alias") - das hat nichts mit Hotspots zu tun. Hier musst du deine Menu struktur ändern. Das hier lesen: forum.joomla.org/viewtopic.php?t=628224

>>> Betriebsblind, danke.


2. Versuchst du hier den Standardschatten auszuwählen oder einen Schatten hochzuladen?

>>> Standardschatten ausgewählt. Komischerweise ging es bei fast allen anderen.
  • Page:
  • 1
Time to create page: 0.156 seconds