×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Keine Kartenansicht bei meinem Template

Keine Kartenansicht bei meinem Template 10 years 3 months ago #15629

  • Scheid Alexander
  • Scheid Alexander's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Hallo alle zusammen,

ich habe jetzt shon sämtliche Beiträge hier durchforstet, aber leider komme ich auf keine Lösung meines Problems.

Mein Problem stellt sich wie folgt dar:

- Installation problemlos
- Konfiguration von HotSpot und Backend alles in Ordnung und geht
- Im Frontend einen Link zum HotSpot erstellen geht auch, aber....

wenn ich auf den Link gehe, wird mir zwar der Rahmen der Karte angezeigt, aber irgendwie fehlt die Karte :(
Ebenso zerschießt es mir mein Auswahlmenü auf der linken Seite :dry:

Könnte man mir vielleicht einen Lösungsvorschlag geben, was ich ändern muss!?

meine HP

Alex

Re: Keine Kartenansicht bei meinem Template 10 years 3 months ago #15632

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hallo Alex!
So ich würde empfehlen firebug für firefox zu installieren und dir ein paar tutorials im yootube anzuschauen, dann wirst du die folgenden JS Konflikte auf deiner Seite:

google is not defined
[Break On This Error]

google.maps.LatLng.prototype.toArray = function() {

jsn_do...519.php (line 1596)
JSNTemplate is undefined
[Break On This Error]

swfobject.embedSWF(

anfahrt (line 218)
swfobject is undefined
[Break On This Error]

swfobject.embedSWF(

anfahrt (line 218)
Hotspots.Hotspot is not a constructor
[Break On This Error]

...spots.Single = new Hotspots.Hotspot(Hotspots.DefaultOptions, 'map_canvas', hotsp...


Das ganze kommt von deinem template und die minifying option. Also minifying ist nicht schlecht, aber mann muss die Reihenfolge beachten. Zu erst müssen die google Scripts geladen werden, dann muss mootools geladen werden und zuletzt kommen die js Dateien von hs.

Bei dir sieht es momentan nicht so - zuerst wird mootols und hotspots geladen und erst danach die google maps api.

Hoffentlich diese Info hilft dir weiter, lass mich wissen ob du irgendwo noch hilfe brauchst!
Mit freundlichen Grüßen,
Daniel

Re: Keine Kartenansicht bei meinem Template 10 years 3 months ago #15633

  • Scheid Alexander
  • Scheid Alexander's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Hallo Daniel,

danke erstmal für deine Antwort, aber ehrlich gesagt verstehe ich nur Bahnhof. Firebug ist mir klar was das ist und was er kann, aber ich weiß leider nicht wirklich wie ich mit ihm arbeiten soll. Wo ändere ich denn die Reihenfolge, wie die Sachen geladen werden?

Re: Keine Kartenansicht bei meinem Template 10 years 2 months ago #15635

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Alex,
Also in deinem Template params hast du höchstwahrscheinlich die Option für js minify. Die musst du ausschalten und dir eventuell eine andere Extension suchen die die minifying macht. Wenn du die minifying option in deinem template ausschaltest dann wird Hotspots höchstwahrscheinlich anfangen zu funktionieren.

Gruß,
Daniel
The following user(s) said Thank You: Scheid Alexander

Re: Keine Kartenansicht bei meinem Template 10 years 2 months ago #15636

  • Scheid Alexander
  • Scheid Alexander's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Also danke für die Info mit dem Abschalten von minify.

Ich habe noch ein wenig danach gegoogelt und siehe da - es ist gar nicht so schwar es abzuschalten! Sollte also jemand auch Probleme damit haben, bei mir reichte es einfach in meinen Template-Einstellungen

CSS/JS Komprimierung "abzuschalten"

wobei ich die CSS-Komprimierung an gelassen habe.

Danke nochmal und: Hotspot ist ein TOP-Programm :lol:
  • Page:
  • 1
Time to create page: 0.126 seconds