×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION

Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION 3 years 6 months ago #26298

  • Igor
  • Igor's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 3
Hello!
1. After install, in admin panel I see this warning all the time (See attachment 1)
I cheked API key - everything done...
2. After checking how sending mail from my site work, I have warnig from Joomla! (See attachment 2)
Can anybody help me please?
Joomla! 3.3.0
Attachments:
The following user(s) said Thank You: Stefan Basting

Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION 3 years 6 months ago #26303

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hey Igor,
Look in your joomla backend under system -> system information. Is safe_mode off on your server? It should be set to off, so if it isn't talk to your admin about it.
Regards,
Daniel

Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION 3 years 6 months ago #26308

  • Igor
  • Igor's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 3
Hmm..
Yes, Safe Mode is OFF

Attachments:
The following user(s) said Thank You: Stefan Basting

Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION 3 years 6 months ago #26318

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hey Igor,
Since I see that the extension seems to work, can you go in:
/libraries/cmandrill/query/query.php
ON line 137 you have:
curl_setopt($ch, CURLOPT_FOLLOWLOCATION, true);

remove this line and check if the extension is still working after that.

Thanks,
Daniel

Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION 3 years 6 months ago #26321

  • Igor
  • Igor's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 3
I commented this line
// curl_setopt($ch, CURLOPT_FOLLOWLOCATION, true);
and all warnings disappeared and extension still works! Thank's!
And what to do with the second problem? After sending a letter from my site I keep getting this warning


May be the problem is in Mandrill and not in your extension?
Attachments:

Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION 3 years 6 months ago #26324

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
When we created the cmandrill extension mandrill didn't have support for emails that had cc . That is why we are sending through phpmailer. You should actually not see this warning as it should go into the error log and it should not be shown to the user.

Set error reporting in your global config to none and make sure that debug is also turned off.

Currently mandrill is supporting mails with CC and we should address this in the next update.
Regards,
Daniel
The following user(s) said Thank You: Stefan Basting

Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION 3 years 6 months ago #26327

  • Igor
  • Igor's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 3
Thank you for detailed answer! I am looking forward for the next update of your useful extension!
Regards,
Igor
The following user(s) said Thank You: Stefan Basting
  • Page:
  • 1
Time to create page: 0.332 seconds