×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Fehlermeldung

Fehlermeldung 8 years 11 months ago #21838

  • Heinz Köhnen
  • Heinz Köhnen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Hallo nach Installation auf Joomla 2.5 erhalte ich folgende Fehlermeldung:
Veranstaltungsübersicht


Warning: require(__DIR__/modern_eventlist.php) [function.require]: failed to open stream: No such file or directory in /var/www/web1179/html/TERMINKALENDER/components/com_matukio/views/eventlist/tmpl/modern.php on line 168

Warning: require(__DIR__/modern_eventlist.php) [function.require]: failed to open stream: No such file or directory in /var/www/web1179/html/TERMINKALENDER/components/com_matukio/views/eventlist/tmpl/modern.php on line 168

Fatal error: require() [function.require]: Failed opening required '__DIR__/modern_eventlist.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/web1179/html/TERMINKALENDER/components/com_matukio/views/eventlist/tmpl/modern.php on line 168

kann mir da jemand helfen?
Danke.

Fehlermeldung 8 years 11 months ago #21839

  • Yves Hoppe
  • Yves Hoppe's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 3519
  • Karma: 71
  • Thank you received: 556
Hallo Hans,

das sieht nach einer sehr veralteten PHP Installation aus - Matukio 2.2 benötigt mindestens PHP 5.3. Ältere Versionen sollten auch schon aus Sicherheitsgründen nicht mehr eingesetzt werden.

Weitere Details zu dem Fehler inkl. eines Workarounds:

compojoom.com/forum/2-general-talk/18028...ter-upgrade-to-2-2-1

Viele Grüße

Yves

Fehlermeldung 8 years 11 months ago #21840

  • Heinz Köhnen
  • Heinz Köhnen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Hm, laut meinem Provider reicht ein Eintrag in die .htaccess für PHP 5.3
dies habe ich gemacht, aber es erschein die gleiche Fehlermeldung

Fehlermeldung 8 years 11 months ago #21841

  • Yves Hoppe
  • Yves Hoppe's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 3519
  • Karma: 71
  • Thank you received: 556
Hmm was soll das den für ein Eintrag seien? Ich kenn nur AddHandler php53-cgi .php (was bei den meisten Providern nicht funktioniert da sie inzwischen auf Module umgestiegen sind)? Hast du das auch in die .htaccess Datei des Wurzelverzeichnisses eingetragen? Was sagt denn die PHP Version im Backend unter Joomla -> Systeminformationen?

Viele Grüße

Yves

Fehlermeldung 8 years 11 months ago #21842

  • Heinz Köhnen
  • Heinz Köhnen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
PHP Version 5.2.17-0.dotdeb.0

der Eintrag sollte sein:
AddHandler x-httpd-php53 .php

Den habe ich natürlich nur in der htacces des Joomlaverzeichnisse gemacht.
Wenn ich den in Root eintrage, weiß ich ja nicht, ob die anderen Scripte noch laufen.

Ich werde aber mal auf einen anderen Account aufsetzen. Vielleicht funktioniert es dort.

Fehlermeldung 8 years 11 months ago #21843

  • Heinz Köhnen
  • Heinz Köhnen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Hmm
alle haben nur PHP 5.2.17
ich habe noch einen Versuch, aber was mache ich dann?

Fehlermeldung 8 years 11 months ago #21845

  • Heinz Köhnen
  • Heinz Köhnen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Ich glaube, ich werde es für heute erst einmal bleiben lassen.
Bei dem einzigen Provider von mir, der PHP 5.3 hat, kann ich keine Componenten installieren, das muss ich erst mal abklären.
Viele Grüße
Heinz

Fehlermeldung 8 years 11 months ago #21847

  • Yves Hoppe
  • Yves Hoppe's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 3519
  • Karma: 71
  • Thank you received: 556
Hallo,

also ich würde schon aus Sicherheitsgründen auf eine aktuellere PHP Version bestehen, es gibt aber wie gesagt auch durch eine Code-Änderung die Möglichkeit das ganze unter PHP 5.2 laufen zu lassen - das __DIR__ muss in der Datei durch dirname(__FILE__) ersetzt werden.

Weitere Informationen dazu stehen auch im Link den ich im ersten Beitrag gepostet habe.

Viele Grüße

Yves
The following user(s) said Thank You: Heinz Köhnen

Fehlermeldung 8 years 11 months ago #21848

  • Heinz Köhnen
  • Heinz Köhnen's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Danke, ich habe es nun auf einem anderen Account ans Laufen gebracht.
Vielen Dank für Deine Mühe.
Gruß
Heinz
  • Page:
  • 1
Time to create page: 0.143 seconds