×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: translation

translation 14 years 3 months ago #8353

  • Beata
  • Beata's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
Hello,

Please advise what I should translate that Joomcomments were in my native default language?

I don't find it

translation 14 years 3 months ago #8355

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
which joomlacomment version are you using and what is your native language?

translation 14 years 3 months ago #8369

  • Beata
  • Beata's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
I have Joomlacomment and need to translate it into Lithuanian language

!JoomlaComment 4.0 beta1
and
!JoomlaComment 4.0 alpha3

How I can do it, which files and where they are

translation 14 years 3 months ago #8372

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
I am on !JoomlaComment 4.0 beta 2, but from what I see the structure is close enough to assume it works the same way.

Take alook in:
joomlaROOT/components/com_comment/joscomment/language

-in my version the component is already available with Lithuanian language ready for use. :)

If you are using JoomFish to handle this stuff, take a look at this: Language support in JoomFishthread .

translation 14 years 3 months ago #8374

  • Beata
  • Beata's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
Yes, really it is. And I remember that some time ago I did translation myself but it didn't appeared in one of my website. Today I see, it works.

In other my website with JoomlaComment 4.0 alpha3
I put Lithuanian file today, but after refreshing I don't see translated for a while. Maybe it will appear later ?

translation 14 years 3 months ago #8375

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
Hm... sounds weird...
It should show up straight away, once you have the settings correct for JoomFish to see it, if you use that.
Maybe you have some cache issue, either on your server or local. If you press F5 (refresh), does that help?
If not, there is probably something else going on. Just guessing..

translation 14 years 3 months ago #8385

  • Beata
  • Beata's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
Yes I use Joomfish.
It is strange to me as well, because it seems that translation don't appear at once .

In this website I did some time translation, but in that time it didn't appear and I left it
www.bajorusajunga.lt

Now I did a new website
www.vilniaustautodaile.lt/index.php?opti...temid=100014&lang=lt
and started to search about translation in this forum, and as I said putting that file in right place didn't help. Maybe some time later thransaltion will appear

Refreshing (F5) and even looking with new browser doesn't help.

B.T.W. My website uses 4 languages, if there are some other trnslation file, they should work ???

translation 14 years 3 months ago #8388

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
If your site uses 4 languages or 20, it shouldn't be a problem for your system. It is just not always easy to know where a problem may be.
But when it is fixed, THEN it seems easy! :laugh:

As I mentioned previously, check again your file: joomla -> components -> com_comment -> joscomment -> utils.php

Check that it truly contains your Lithuanian acknowledgement.

When I looked on your site, it first defaulted to English.
I then pressed the Lithuanian flag, and it came up in Lithuanian.
Now when I repress it, it seems to always default to Lithuanian. Which, is kind of correct... :dry: isn't it?

And the Comment system seems to be working fine in your language too...

translation 14 years 3 months ago #8408

  • Beata
  • Beata's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
Thank you for answer

1.I have checked www.bajorusajunga.lt (never did know about utils.php) - there isn't lithuanian, but it is lithuanian.php in Languages folder
..but Comments works in Lithuanian (they started to work not at once after some time...
For me this website opened in Lithuanian firstly but I am not sure that always. It seems sometimes not. What a reason?
Lithuanian is default and in Joomfish indicated as the first language.

2. I have checked utils.php, in my second website www.vilniaustautodaile.lt there isn't indicated lithuanian in utils.php as well

Should I simple add this:
case 'lt-LT':
		$language = 'lithuanian.php';
break;
I did it and it works. Thank you. Where was written about utils.php?

Lithuanian is default and in Joomfish indicated as the first language.

Questions::
1. why in first website Comments appeares translated without lithuanian in utils.php and in the second website don't?
2. Why sometimes website opens not in default language? Maybe this is a reason that I firstly translate my core joomla modules and other things in Lithuanian and only later I translate everything from Lithuanian to other languages? Can be this isn't OK? Should I leave core Joomla in english and it translate to Lithuanian ? Sorry if this question isn't in place in your forum, because I came to ask about Comments...

translation 14 years 3 months ago #8410

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33

Questions::
1. why in first website Comments appeares translated without lithuanian in utils.php and in the second website don't?
2. Why sometimes website opens not in default language? Maybe this is a reason that I firstly translate my core joomla modules and other things in Lithuanian and only later I translate everything from Lithuanian to other languages? Can be this isn't OK? Should I leave core Joomla in english and it translate to Lithuanian ? Sorry if this question isn't in place in your forum, because I came to ask about Comments...


Things like this is often for the same reason as why socks disappear :laugh: (joking).
To me it seems like your question number 2 is perhaps answering nr one.

Leave the core in English, as it installs, and install the language files as they should be.
Hehe, I did the same thing a couple of years back, by just renaming the Norwegian language files to the English filenames. It worked, seemingly, but the system was thinking it was giving Englishg out, but it was giving Norwegian visibly.
So of course, the default was in fact English, just with a different spelling.

=util.php is nicely documented in the documentation files. :laugh:
Sorry, joking again, I saw it in another post and mentioned it previously here, but since you were still having the same problems, I just assumed that you didn't go there.

On your www.vilniaustautodaile.lt site, it seems you have English mixed in there, as articles start off: Written by Administratore
Tuesday, 29 December 2009 03:26

-and the Read more is also English.

translation 14 years 3 months ago #8425

  • Beata
  • Beata's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
In my second website there are only a couple articles translated in other languages

As for "Leave the core in English, as it installs,:. It is too late. All my websites are done in this way: firstly everything done in Lithuanian, later I translate in other languages

With the last website I thought that I do silly, by renaming all modules into Lithuanian, later in oposite :-)

Good, with the next new website (or by redoing some) I will leave the core in English, as it installs,

Thank you :-)

translation 14 years 3 months ago #8426

  • Beata
  • Beata's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
Nils Ally wrote:

On your www.vilniaustautodaile.lt site, it seems you have English mixed in there, as articles start off: Written by Administratore
Tuesday, 29 December 2009 03:26

-and the Read more is also English.


By the way, In this website With enabled plugin "Joomfish - Missing_translation" I get wrong even on Lithuanian articles "There is not translated", thefore this plugin is disabled here by me

Why it works in such way, I don't understand, maybe this Joomfish bugs, because a little older Joomfish version works fine with enabled plugin

P.S. Suddenly it has improved herself when I switched into enable, maybe utilps.php helped :-)

translation 14 years 3 months ago #8428

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
JoomFish is a bit more tricky to get in place than it at first seams actually. Well, at least I thought so...

I also use it, and firstly I have to translate the base language to it's own language, prior to the next translation.

For example, an article in English, I must first just duplicate translate to English, and from there translate further to other languages.
-Otherwise it was defaulting wrong for some reason.

Once I figured that out, I stick to it, and it works.
Don't know why, as I can also state the base language already from the backend directly in each article from content items.

But regardless, that's at least how it is for me.

Just thinking: it seems to me that articles from Joomla are being stored in such a way that JoomFish needs its own ID or direction for, to be able to log it as either a default or a translation. Which would explain why it wants stuff this way. Just a thought...

It is smart to get it right, as steadily more browsers have a translation Addon built into them, making on-the-fly translations possible, as long as it "sees" the correct language.

As for leaving the core in English, well, as long as you have control over it all, I guess it doesn't really matter.
  • Page:
  • 1
Time to create page: 0.157 seconds