×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me

TOPIC: display AFTER content?

display AFTER content? 8 years 10 months ago #2504

  • Lilith Nerevarine
  • Lilith Nerevarine's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 24
Oooops, I forgot to say thanks for the reply :)
I have started another project meanwhile, didnt have the time to meddle with this matter, so my problem still exists. :huh:
Would be interested in a solution still.

Nice day, guys!

display AFTER content? 8 years 10 months ago #2508

  • Shaiful
  • Shaiful's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 72
Hi there,

Give me the URL so I could have a look.

TQ

display AFTER content? 8 years 9 months ago #2709

  • Jeffrey Kiefer
  • Jeffrey Kiefer's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 16
I too am having problems. I was able to get the comments to display after the readmore link bu inserting onAfterDisplayContent::JOSCusereturn in the mambot content function but I am unable to fix how the comment link appears. There is there is too much space between read more and write a comment and no space between write comment and the next article.
Here is a link
alzheimersalmanac.com/articles.html

display AFTER content? 8 years 9 months ago #2730

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hey Jeffney!
Your problem has nothing to do with the specified function, but with the css of your template. I sent you a PM with a proposal how to change it.

display AFTER content? 8 years 9 months ago #2731

  • Shaiful
  • Shaiful's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 72
Yeah I doubt it has anything to do with the joomla codes. Thanks Daniel!

display AFTER content? 8 years 9 months ago #2736

  • Jeffrey Kiefer
  • Jeffrey Kiefer's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 16
Yes that gave me what I needed to set the css.
Thanks!

display AFTER content? 8 years 9 months ago #2779

  • Helly
  • Helly's Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 29
  • Thank you received: 8
Ruben Goethals wrote:

Is there any way to place the comment plugin AFTER the content, after my other plugins?
I tried changing the "onPrepareContent" in the settings to "onAfterDisplayContent", but it stays.

Problem is that now, my "Written by" and "Vote" etc.. plugins all display behind the comments. That's very awkward.


onAfterDisplayContent
works here as of 15.40 this afternoon (tried , tested and approved)
hope it helps other people

display AFTER content? 8 years 9 months ago #2964

  • Mags Ingval
  • Mags Ingval's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 8
Re:display AFTER content? 2 Weeks ago Karma: 30
Hey Jeffney!
Your problem has nothing to do with the specified function, but with the css of your template. I sent you a PM with a proposal how to change it.
I probably suffer from the same thing...can you PM me a proposal as well?

display AFTER content? 8 years 9 months ago #2965

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
I cannot give you a proposal, since I don't know your web site.

display AFTER content? 8 years 8 months ago #3168

  • Nick Osinski
  • Nick Osinski's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 32
Hello,

I've tried using the tip in this thread, but cannot make it work. I have the latest version of Joomla and your component installed, but if I just changed the mambot field from:

onPrepareContent

To:

onAfterDisplayContent::JOSCusereturn

Nothing changes. What am I missing?

Thanks in advance for your help!

display AFTER content? 8 years 8 months ago #3169

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Do you have afterDisplayContent event in your article template?

display AFTER content? 8 years 8 months ago #3170

  • Nick Osinski
  • Nick Osinski's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 32
Hi,

I'm confused; this thread says that if you're running 1.5 then there is no code changes to make. When you ask if I have afterDisplayContent even in my article template - do you mean onAfterDisplayContent or afterDisplayContent? My template shows just afterDisplayContent as I have not changed it.

Thank you again for your assistance.

display AFTER content? 8 years 8 months ago #3171

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Yes and no.
Normally you don't have make any no code changes to use this behavior, but! If your template is making use of template override ( docs.joomla.org/Tutorial:Template_overrides ) and your template doesn't have the necessary code in there, then it is possible that it won't work.

Could you try this with milkyway template?

display AFTER content? 8 years 8 months ago #3172

  • Nick Osinski
  • Nick Osinski's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 32
Thank you for your prompt reply.

Unfortunately, this is for a live site for which we cannot change the template. Is there anything else that can be done/tried?

Thanks again.

display AFTER content? 8 years 8 months ago #3174

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Make a new menu entry and make it visible only for special users. Then go to your template and assign milkyway for this menu entry and ready. :)

display AFTER content? 8 years 8 months ago #3175

  • Nick Osinski
  • Nick Osinski's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 32
Thanks!

Very strange... I test it it with the Milkyway template and it works there... the strange thing is that it NOW works on our live template ALSO!

Not sure why it just started working, but it did. Can you explain possibly?

Thanks again!

display AFTER content? 8 years 8 months ago #3177

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
cache was on?

display AFTER content? 8 years 8 months ago #3306

  • RachelSoma
  • RachelSoma's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 24
I'm having the same issue as some people upthread. My comments link is now below the 'read more' but the next article is wrapping around it. You can see it at http://www.nerdgirlarmy.com

I appreciate any help given.

Thanks!
Rachel

display AFTER content? 8 years 8 months ago #3307

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Rachel that is a css problem and not one connected in any way with display AFTERcontent.

open you !jooomlacomment template and find the following code:
{readon}
	<div class='write_comment'>
		<a href="{READON_LINK}#JOSC_TOP" class="readon">{READON_WRITE_COMMENT} ({READON_COUNT} {READON_COMMENTS})</a>
	</div>
	{BLOCK-preview}
	<div class='comment_preview_container'>
		{preview-lines}
	</div>
	{/BLOCK-preview}
{/readon}

change it to this:
{readon}
	<div class='write_comment'>
		<a href="{READON_LINK}#JOSC_TOP" class="readon">{READON_WRITE_COMMENT} ({READON_COUNT} {READON_COMMENTS})</a>
	</div>
	{BLOCK-preview}
	<div class='comment_preview_container'>
		{preview-lines}
	</div>
<div style="clear:both"></style>
	{/BLOCK-preview}
{/readon}

display AFTER content? 8 years 8 months ago #3317

  • RachelSoma
  • RachelSoma's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 24
Thank you for your help but I'm afraid the it has not resolved my issue :(

I have also tried using the milkyway template but the same issue occurs.
Time to create page: 0.121 seconds