×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Incomplete comments are shown

Incomplete comments are shown 12 years 9 months ago #7472

  • Jiri medaacek
  • Jiri medaacek's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 8
Hello,
went through the topics here but have not found the solution. I had the component installed some time ago but had some troubles with that so I left the comment function. Recently I have updated my Joomla instalation and other stuff and also updated the JoomlaComment component. The issue I have on my web are the incomplete comments - sometimes I can only see 6 letters, sometimes 16, sometimes 20 but the user comments must be mcuh longer as the words suddenly ends in the middle. I tried to post comment just to check and everything was fine - where might be the problem?
the setting is max. 2000 character, 80 per line, 50 word lenght.

www.jirislama.com

the comments are incomplete in the database too.

thanks for your help

Incomplete comments are shown 12 years 9 months ago #7476

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
isn't it possible that the user entered incomplete comments since they are also incomplete in the database?

Incomplete comments are shown 12 years 9 months ago #7478

  • Jiri medaacek
  • Jiri medaacek's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 8
Well I would guess no...
OK, now when I looked at the broken comments I realized where might be the problem - all the comments are broken before the special characters (ě, é, š and some others) in the word should follow. Is there any way to solve this issue?

Im not the joomla magician so it might be stupid problem - in Joomlacomment/Content settings/General the local charset is CP1250 while the charset of my joomla installation (the database charset if I understood well) is utf8_general_ci.

Do you think I should change the database charset to utf8_czech_ci to display all the special characters properly? Or change something in the JoomlaComment setting?

Thanks a lot for your help!!!

Incomplete comments are shown 12 years 9 months ago #7479

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
yep, that sounds as a character problem. Change everything to utf8 and it should work properly.

Incomplete comments are shown 12 years 9 months ago #7480

  • Jiri medaacek
  • Jiri medaacek's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 8
Oh yes, this was it! Thanks a lot and stupid me!!!

Best Regards

Jiri
  • Page:
  • 1
Time to create page: 0.160 seconds