×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Swedish sv-SE.com_hotspots.ini issues

Swedish sv-SE.com_hotspots.ini issues 6 years 1 week ago #14611

  • Albert Kuilderd
  • Albert Kuilderd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 0
When I downloaded V2.0.5, it came with a language file sv-SE.com_hotspots.ini. I uploaded this file to /language/sv-SE.
The front and back end files has already been uploaded for Joomla - sv-SE
There is a problem when I look at the front end the Swedish does not show in hotspots
Any idea's would be helpful.
www.ffkb.ahkdesigns.com

Swedish sv-SE.com_hotspots.ini issues 6 years 1 week ago #14614

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hey Albert,

You are on joomla 1.7 right? Then go to global configuration and enable language debug. Once you do this on the frontend down at the bottom you will see a text - showing what language files are loaded. Is sv-SE.com_hotspots.ini there?

Kind regards,
Daniel

Swedish sv-SE.com_hotspots.ini issues 6 years 1 week ago #14615

  • Albert Kuilderd
  • Albert Kuilderd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 0
Actually I am still in the old school J1.5. I have checked and the INI is present but does not translate the full text as in the INI. as the INI file I believe is meant for J1.5 or is the wrong, should it be J1.6 or 1.7

Swedish sv-SE.com_hotspots.ini issues 6 years 1 week ago #14620

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Yep, the ini should work on 1.5, 1,.6 and 1.7... I'm afraid that I'm out of ideas for now.

Can you provide me with admin and ftp access to your website? Use the contact us button at the bottom.

Cheers,
Daniel

Swedish sv-SE.com_hotspots.ini issues 6 years 1 week ago #14621

  • Albert Kuilderd
  • Albert Kuilderd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 0
Hey Daniel,

Are we talking about the same thing "Hotspots"
If you look on the websitehttp://www.ffkb.ahkdesigns.com/index.php/sv/fangsterna/laga-en-hake.html see that some of the Swedish is not translated, but in INI file located /public_html/ffkb/language/sv-SE is all translated.
Hope this gives you what you need.

Regards
Albert

Swedish sv-SE.com_hotspots.ini issues 6 years 1 week ago #14623

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hey Albert,
I'm sorry! For some reason I was all the time thinking of ccomment. I'll check it now and will let you know what I found.
Daniel

Swedish sv-SE.com_hotspots.ini issues 6 years 1 week ago #14624

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Ok, now it is in Swedish. I don't understand why this things happens on your configuration - it should actually work properly. You see the problem is that joomla first loads the SV translation and then the english one. And it should be the other way around - it should load the english translation, then overrride it with the SV. this way - all untranslated strings in your language will be at least in english and you won't wonder what the meaning of COM_HOTSPOTS_ADD_FORM should be.

But for some reason that I don't understand it doesn't work on your site as intended.

I've commented the code in components/com_hotspots/hotspots.php
//$jlang->load('com_hotspots', JPATH_SITE, 'en-GB', true);
//$jlang->load('com_hotspots', JPATH_SITE, $jlang->getDefault(), true);
//$jlang->load('com_hotspots', JPATH_SITE, null, true);
//$jlang->load('com_hotspots', JPATH_ADMINISTRATOR, 'en-GB', true);
//$jlang->load('com_hotspots', JPATH_ADMINISTRATOR, $jlang->getDefault(), true);
//$jlang->load('com_hotspots', JPATH_ADMINISTRATOR, null, true);

This code is responsible for the proper loading of the language files - as I said something strange is going on your site - maybe a language plugin???

Anyway - now only the sv file is loaded and you will see some untranslated strings. So please add them to your SV translation and give me the updated files and I'll put it in the next release.

Cheers,
Daniel

Swedish sv-SE.com_hotspots.ini issues 6 years 4 days ago #14638

  • Albert Kuilderd
  • Albert Kuilderd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 0
Thanks Daniel for your help and support, all works great, will have a look at the language loading for Joomla.

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 8 months ago #15611

  • Jenny Forsberg
  • Jenny Forsberg's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
Hi,

I had the same problem. And after a whole day of trying different things i saw that womething was wrong with the swedish language-file, a " is missing!

COM_HOTSPOTS_END_ADDRESS="Måladress
should be
COM_HOTSPOTS_END_ADDRESS="Måladress"

When i solved that problem it worked like a charm!

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15855

  • Krister Andersson
  • Krister Andersson's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
I also have problem with loading the swedish file.
Im on joomla 2.5 and latest hotspot



//Kribba

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15856

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hey Krister,
Did you make the suggested change from Jenny?
language/your-language/your-language.com_comment.ini

Daniel

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15857

  • Krister Andersson
  • Krister Andersson's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
Yes, the " signs is there. Still not work

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15860

  • Krister Andersson
  • Krister Andersson's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
Hmmm dont even have a file called sv-SE.com_comment.ini
Or did you mean sv-SE.com_hotspot.ini?

What is this file for?

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15862

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
I'm sorry. Yes I meant com_hotspots.

Go to global config in the backend and enable debug mode + language debug. Then in the frontend refresh the page and look at the output at the bottom of the site -> does it say "parsing language files problems" If it does, then please look at the indicated lines and check what is wrong with them.

If you can't fix it on your own, don't hesitate to provide me with ftp + admin access to your site and I'll have a look tomorrow morning (create a private ticket for this)

Kind regards,
Daniel

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15863

  • Krister Andersson
  • Krister Andersson's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
ok thanks.

JROOT/administrator/language/en-GB/en-GB.com_hotspots.ini : fel i rad 122, 149, 151, 307, 325

But still cant figure out what it is. Cant see anything wrong with it so far.
Will check some more, but I will make a ticket if I cant sort it out.

Thanks for the help

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15866

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Hey Krister,
Please go here:
opentranslators.transifex.net/projects/p/compojoom-hotspots/
And download the english + swedish translations. (you have admin_com_hotpsots -> this one is for administrator/langauge and frontend_com_hotspots -> this one is for the language/ folder). Those files there have been tested only on 2.5 and they should work for sure and should not contain any errors. If the problem persist, submit a ticket and I'll take care of it!
Daniel
The following user(s) said Thank You: Krister Andersson

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15870

  • Krister Andersson
  • Krister Andersson's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
Thanks. Works now.

And thanks for a really good extension och fast support. Best there is.
Keep up the good work.

//Regards, Kribba

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15873

  • Krister Andersson
  • Krister Andersson's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
One problem remains tho.
And that is jomsocial plugin shows like this JOMSOCIAL_ADDHOTSPOTS.
I have taken the fils from your link but seams like the file not even loaded.


EDIT: The plugin file itself is located in the plugin folders root. All other plugins I have for jomsocial is within /plugin/community/ folder

This is right? It should be in root of plugin folder?

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15877

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
What do you mean with the plugin is located in the root? it should be in hotspots/jomsocial

The language file for it should be in administrator/language
and the plugin loads them automatically actually...

Ah and you will need to add a new hotspot to see if it is translated or not. Jomsocial stores the translations - if in the past there was a problem with that plugin, then that is why you see it as JOMSOCIAL_ADDHOTSPOTS

Cheers,
Daniel

Re: Swedish sv-SE.com_hotspots.ini issues 5 years 7 months ago #15879

  • Krister Andersson
  • Krister Andersson's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 0
I did that. Diden't work. But somehow, it works now :D

However the work flygfält is cut like this "flygf"
Like - xxx has added new flygfält. But it says flygf

It should support swedish letters as åäö?
  • Page:
  • 1
  • 2
Time to create page: 0.122 seconds