×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Scandinavian characters smash after open comment in Administrator side

Scandinavian characters smash after open comment in Administrator side 6 years 9 months ago #11148

  • Wild Map
  • Wild Map's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Hi,
When I open comment in administrator side all Scandinavian characters (ääää) smash - those look like äääÃ.
Savin in "Edit Comment" is Ok but opening is problem.

I using newest version (4.1.7). My earlie version was 4.0 and it works fine.

Br. Markko

Scandinavian characters smash after open comment in Administrator side 6 years 9 months ago #11149

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
Hm... I use Norwegian and it all works fine in 4.1.7 here.
Have you checked the charset?

Scandinavian characters smash after open comment in Administrator side 6 years 9 months ago #11150

  • Wild Map
  • Wild Map's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Charset is set UTF-8. I upgrade comments fron 4.0 to 4.1.7 and after that problems begin. Strange thing is that if I open comment I find this kind of characters ääää not äääää but I can type in edit mode normal Scandinavian characters äääää. After save I have both type of characters.

Scandinavian characters smash after open comment in Administrator side 6 years 9 months ago #11152

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
This looks like a problem in the input charset.
If I remember correctly, this has been addressed a few times before.
From memory (I will check if this is correct), the problem sits in the charset settings of the SQL.
But this is out of what I know... but Daniel know this stuff good!

Scandinavian characters smash after open comment in Administrator side 6 years 9 months ago #11153

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
This thread I think addresses your problem: LOOK HERE

Scandinavian characters smash after open comment in Administrator side 6 years 9 months ago #11157

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Yep Nils this is a good thread.
Again - check the table collation and the fields collation inside the table.

Scandinavian characters smash after open comment in Administrator side 6 years 9 months ago #11159

  • Wild Map
  • Wild Map's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Thanks for you great help, but it didn´t solve the problem. Charset settings of the SQL are utf8_general_ci. I have tested components in two differend servers and both do same thing. Component is great but I cant use it until it works...

Scandinavian characters smash after open comment in Administrator side 6 years 9 months ago #11160

  • Nils Ally
  • Nils Ally's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 299
  • Thank you received: 33
See INSIDE the table from your Phpmyadmin.
You can see there is a field at the top of the SQL page, that gives you TABS of commands or viewpoints.
On the left it says "Browse" (if I remember correctly), and then loads of others, (Insert, drop etc).
I think the Browse function will show the collation... but, this is just roughly from memory (I don't have access to my Admin just now).

Scandinavian characters smash after open comment in Administrator side 6 years 9 months ago #11161

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 154
  • Thank you received: 1081
Yes, make sure that you check out what Nils says. If you see utf8 everywhere I will have to check this myself. But first please make sure you do what Nils says :)
  • Page:
  • 1
Time to create page: 0.109 seconds