×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Mailfunction error again

Mailfunction error again 9 years 8 months ago #15442

  • benny hermans
  • benny hermans's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 0
Hello,
In the past i had an error where users saw appearing a script saying xml error can not start mailfunction. By then this error appeared after changing the smilies and was solved by the ticket-system. Weird thing is that after changing the smilies again, users are getting the same error again.
Pls help

Re: Mailfunction error again 9 years 8 months ago #15443

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Benny,
I can't remember the exact case anymore, but do you have a test system where I can see the error.

"could not start mailfunction" means that the mail function on your server is failing to send the emails to those users subscribed for notifications (or moderators). I can't imagine that the smilies have anything to do with that.

Kind regards,
Daniel

Re: Mailfunction error again 9 years 8 months ago #15444

  • benny hermans
  • benny hermans's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 0
This is the link to the topic with the error back then:
compojoom.com/forum/45-newbies-area/1435...-mail-function#14360

Re: Mailfunction error again 9 years 8 months ago #15449

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Benny,
I tried to post a comment on your site and I got a message saying that the comment needs to be approved - I didn't get any error message.

In joomla's global configuration - do you use smtp or the php mail function? Can you try to configure your website with something else than what you are using now? for example if you use PHP mail, change to SMTP. I'm more than 99% sure that there is something wrong with the mail server from time to time and it just happens that the user posts a comment when your mail server is having problems.

Cheers,
Daniel

Re: Mailfunction error again 9 years 8 months ago #15453

  • benny hermans
  • benny hermans's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 0
Thx Daniel,
I changed global configuration to smpt and the error dissapeared for me as well. Maybe i should contact my host to check why it is hapening from time to time, but u should agree it is weired it happens when i change smilies. Anyway it seems solved. Tyvm

Re: Mailfunction error again 9 years 8 months ago #15456

  • Daniel Dimitrov
  • Daniel Dimitrov's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9618
  • Karma: 155
  • Thank you received: 1081
Hey Benny,
I think that the smilies thing is just a coincidence.

Anyway! Let me know if you encounter the problem again. If you do, I would really appreciate it if you could setup a test system on your server. This would actually be the only way for me to debug this and figure out why the mail function is complaining there.

Cheers,
Daniel
  • Page:
  • 1
Time to create page: 0.135 seconds